Bug 75618 - Not possible to rpm -ivh gdk-pixbuf-devel-0.18.0-4.i386.rpm
Summary: Not possible to rpm -ivh gdk-pixbuf-devel-0.18.0-4.i386.rpm
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdk-pixbuf (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 11:29 UTC by David
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 11:39:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David 2002-10-10 11:29:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
When installing gdk-pixbuf-devel I get
warning: gdk-pixbuf-devel-0.18.0-4.i386.rpm: V3 DSA signature: NOKEY, key ID
db42a60e
error: unpacking of archive failed on file
/usr/share/aclocal/gdk-pixbuf.m4;3da559e1: cpio: mkdir failed - Not a directory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh --nodeps gdk-pixbuf-devel-0.18.0-4.i386.rpm on a desktop system
2.
3.
	

Actual Results:  warning: gdk-pixbuf-devel-0.18.0-4.i386.rpm: V3 DSA signature:
NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:gdk-pixbuf-devel       ########################################### [100%]
error: unpacking of archive failed on file
/usr/share/aclocal/gdk-pixbuf.m4;3da559e1: cpio: mkdir failed - Not a directory


Expected Results:  It should just install 

Additional info:

Looking at /usr/share/aclocal it is a file of 258Meg in size not a directory.

rpm -qf /usr/share/aclocal  returns
automake-1.6.3-1
libole2-0.2.4-4
automake15-1.5-4

if I run rpm -ql libole2 it returns these lines amongst its output
/usr/share/aclocal
/usr/share/aclocal/gnome-libole2.m4
/usr/share/aclocal/libole2.m4

On my system /usr/share/aclocal is not a directory and so the bottom 2 files do
not and cannot exist.

ls -lh /usr/share/aclocal
?-ws--x-w-  54739 905885785 1740155207     258M Jan  6  2000 /usr/share/aclocal

Can someone check this?
I did a straight install as a desktop with other things added in off the package
selection and then have added a handful of rpm's since then but nothing that
touches this.

Comment 1 David 2002-10-10 11:39:28 UTC
May actually be a problem with automake and automake15 or I have suffered from
file system corruption.

I'll fsck the partition and see if that helps.



Comment 2 Havoc Pennington 2002-10-10 15:16:13 UTC
/usr/share/aclocal is definitely not a 258M file in any of the packages
we provide.

(As an aside, I would suggest using -Uvh instead of -ivh, and avoiding 
--nodeps like the plague...)


Note You need to log in before you can comment on or make changes to this bug.