Bug 756205 - Installer does not go to login page after configuring server
Installer does not go to login page after configuring server
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
Unspecified Unspecified
urgent Severity medium (vote)
: ---
: JON 3.0.0,RHQ 4.3.0
Assigned To: John Mazzitelli
Mike Foley
: 772228 (view as bug list)
Depends On:
Blocks: jon30-sprint9
  Show dependency treegraph
Reported: 2011-11-22 18:12 EST by Deon Ballard
Modified: 2012-06-01 17:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2011-11-22 18:12:38 EST
Description of problem:
The installer does not go to the login page after the server is configured. Instead, clicking the "click here to get started" link goes back to http://myserver:7080/installer/welcome.jsf and the page still says "click here to get started." Going to just http://myserver:7080 also goes back to welcome.jsf; the only way to get into the login page is to manually enter coregui/ in the URL.

Version-Release number of selected component (if applicable):
Build #100 for JON3 Core on hudson.

How reproducible:
Always, for at least a few minutes after installing. I tried restarting the server and restarting Firefox, but it still did it. I reopened Firefox about an hour after install, and then it worked for me, but that could be a browser cache thing.
Comment 1 Heiko W. Rupp 2011-11-23 02:57:41 EST
This is something we have seen with Webkit based browsers in the past; looks like Firefox is finally on par with them.
Shift-reload should help here.
Comment 2 Charles Crouch 2011-11-28 22:05:11 EST
If the fix is simple to append "/coregui" to the end of the link URL we generate in the installer, then lets just do that and resolve this once and for all.
Comment 3 Charles Crouch 2011-11-28 22:52:55 EST
Assigning to Lukas to see if this is a quick, safe fix
Comment 4 John Mazzitelli 2011-11-29 12:21:56 EST
master git commit: 6f563d3
Comment 5 Charles Crouch 2011-11-29 12:48:47 EST
(11:22:40 AM) mazz: ccrouch: https://bugzilla.redhat.com/show_bug.cgi?id=756205 I have this in master. did you say you wanted this in release branch?
(11:27:18 AM) ccrouch: mazz: does it work? :-)
(11:27:27 AM) ccrouch: the change looks trivial

If it works as expected, please push to the release branch
Comment 6 John Mazzitelli 2011-11-29 13:34:01 EST
release_jon3.x commit: bcb04980f718334c8a100195316a7fee5ac258b9
Comment 7 Mike Foley 2011-11-30 10:20:36 EST
verified JON CR3
Comment 8 John Mazzitelli 2012-01-11 16:18:57 EST
*** Bug 772228 has been marked as a duplicate of this bug. ***
Comment 9 Mike Foley 2012-02-07 14:25:07 EST
Comment 10 Mike Foley 2012-02-07 14:28:19 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.