Bug 75633 - Not clear how to move to another workspace with a mouse move
Not clear how to move to another workspace with a mouse move
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 10:45 EDT by Nick Urbanik
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 10:45:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Urbanik 2002-10-10 10:45:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I became adicted to the usefulness of being able to move from one viewport to
another by just moving the mouse.  But it seems this capability has been withdrawn.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.move mouse to edge of screen, hope for it to move to next workspace, no it
doesn't.
2.Search for documentation to fix this.
3.Search results in no ability to flip workspaces when move mouse to edge of window.
	

Actual Results:  Mild frustration, and a lower productivity, and much pressing
of Ctrl-Alt-arrow.

Expected Results:  After a brief delay, found myself in the next workspace.

Additional info:

I also love being able to move windows from one viewport to another.  Must I
switch back to sawfish to do this?  How _do_ i switch back to sawfish?
Comment 1 Havoc Pennington 2002-10-10 12:05:28 EDT
I'm not sure if Sawfish does this or not, a quick google search should turn it up.

Basically how you switch to another window manager is to kill the current one,
run the new one, type "gnome-session-save"

In any case, we have no plans to add this feature at Red Hat, though if it
appears or exists in upstream window managers we will include it. But the
decision rests with gnome.org and other upstream maintainers.
Comment 2 Richard Smith 2004-01-02 15:55:37 EST
Sawfish does this just. It's the reason why I switched back to sawfish
in RedHat 9. 

Just do the following:
Put this line in ~/.bashrc or .profile:
export WINDOW_MANAGER=/usr/bin/sawfish

Create a ~/.sawfishrc with this in it:
;; edge flip options
                                                                     
          
  (require 'sawfish.wm.ext.edge-flip)
                                                                     
          
  (define-special-variable edge-flip-enabled nil
    "Select the next desktop when the pointer hits screen edge.")
                                                                     
          
  (define-special-variable edge-flip-type 'workspace
    "Control what hitting the screen edge selects, workspace or
viewport.")
                                                                     
          
  (define-special-variable edge-flip-only-when-moving nil
    "Only flip when interactively moving a window.")
                                                                     
          
  (define-special-variable edge-flip-delay 250
    "Milliseconds to delay before edge flipping.")
                                                                     
          
Log out.
When you log in, just go to: 
Preferences -> More Preferences -> Sawfish Window Manager -> Workspaces

The "Edge Flipping" tab should be visible. Set it up appropriately,
along with the number of workspaces that you want.

Then log out again, *but* be certain to save your current setup.
When you log in, everything should work just fine.

Note You need to log in before you can comment on or make changes to this bug.