Bug 756333 - SELinux is preventing /usr/lib/iscan/network from 'accept' accesses on the tcp_socket port None.
SELinux is preventing /usr/lib/iscan/network from 'accept' accesses on the tc...
Status: CLOSED DUPLICATE of bug 756334
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-11-23 05:31 EST by Slawomir Czarko
Modified: 2011-11-23 12:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-11-23 12:03:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Slawomir Czarko 2011-11-23 05:31:57 EST
SELinux is preventing /usr/lib/iscan/network from 'accept' accesses on the tcp_socket port None.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that network should be allowed accept access on the port None tcp_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep network /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Objects                port None [ tcp_socket ]
Source                        network
Source Path                   /usr/lib/iscan/network
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-44.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) #1
                              SMP Fri Nov 11 21:43:42 UTC 2011 i686 i686
Alert Count                   2
First Seen                    Wed 23 Nov 2011 10:44:23 AM CET
Last Seen                     Wed 23 Nov 2011 10:47:58 AM CET
Local ID                      a7695acb-27d2-4bbc-b94a-655a55bbee43

Raw Audit Messages
type=AVC msg=audit(1322041678.109:24): avc:  denied  { accept } for  pid=1339 comm="network" laddr= lport=54396 scontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tcontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tclass=tcp_socket

Hash: network,colord_t,colord_t,tcp_socket,accept


#============= colord_t ==============
allow colord_t self:tcp_socket accept;

audit2allow -R

#============= colord_t ==============
allow colord_t self:tcp_socket accept;
Comment 1 Daniel Walsh 2011-11-23 12:03:36 EST

*** This bug has been marked as a duplicate of bug 756334 ***

Note You need to log in before you can comment on or make changes to this bug.