Bug 756335 - SELinux is preventing network from 'listen' accesses on the tcp_socket port None.
SELinux is preventing network from 'listen' accesses on the tcp_socket port N...
Status: CLOSED DUPLICATE of bug 756334
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
15
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:5694fc5f49e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 05:33 EST by Slawomir Czarko
Modified: 2011-11-23 12:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-23 12:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Slawomir Czarko 2011-11-23 05:33:46 EST
SELinux is preventing network from 'listen' accesses on the tcp_socket port None.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that network should be allowed listen access on the port None tcp_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep network /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Context                system_u:system_r:colord_t:s0-s0:c0.c1023
Target Objects                port None [ tcp_socket ]
Source                        network
Source Path                   network
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           iscan-network-nt-1.1.0-2
Target RPM Packages           
Policy RPM                    selinux-policy-3.9.16-44.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.41.1-1.fc15.i686.PAE #1
                              SMP Fri Nov 11 21:43:42 UTC 2011 i686 i686
Alert Count                   2
First Seen                    Wed 23 Nov 2011 10:44:23 AM CET
Last Seen                     Wed 23 Nov 2011 10:47:58 AM CET
Local ID                      97891a68-91c7-4c41-9d78-15d7012e3718

Raw Audit Messages
type=AVC msg=audit(1322041678.109:23): avc:  denied  { listen } for  pid=1339 comm="network" laddr=127.0.0.1 lport=54396 scontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tcontext=system_u:system_r:colord_t:s0-s0:c0.c1023 tclass=tcp_socket


type=SYSCALL msg=audit(1322041678.109:23): arch=i386 syscall=socketcall success=yes exit=0 a0=4 a1=bfc099e0 a2=9eb8008 a3=1 items=0 ppid=1326 pid=1339 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=network exe=/usr/lib/iscan/network subj=system_u:system_r:colord_t:s0-s0:c0.c1023 key=(null)

Hash: network,colord_t,colord_t,tcp_socket,listen

audit2allow

#============= colord_t ==============
allow colord_t self:tcp_socket listen;

audit2allow -R

#============= colord_t ==============
allow colord_t self:tcp_socket listen;
Comment 1 Daniel Walsh 2011-11-23 12:05:15 EST

*** This bug has been marked as a duplicate of bug 756334 ***

Note You need to log in before you can comment on or make changes to this bug.