Bug 75640 - RFE: rpm -Fvh --test should list packages to be freshened
RFE: rpm -Fvh --test should list packages to be freshened
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 11:27 EDT by Peter J. Holzer
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 11:27:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter J. Holzer 2002-10-10 11:27:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020103

Description of problem:
rpm -Fvh *.rpm 
in a directory full of RPMs (e.g., a mirror of the updates directory
from the Redhat FTP server) is a convenient way to update all installed packages.

Doing this blindly is also a bit dangerous since some packages need
special care. So it would be nice to find out what rpm -F will do 
before actually doing it.

Unfortunately the "intuitive" way of invoking

  rpm -Fvh --test *.rpm

does not work. Unlesse there are conflicts, it will only print
Preparing...               ########################################### [100%]
and no indication which packages would be installed.

You can get the information with -vv, but that also prints a lot of
other information which is not relevant for the task at hand.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a directory full of update rpms.
2. Invoke rpm -Fvh --test
3. Invoke rpm -Fvh
4. Compare output. It should be the same, but it isn't.
	

Additional info:
Comment 1 Jeff Johnson 2002-10-10 11:53:40 EDT
This is the traditional behavior of --test.
Use -vv if you want to see what would be installed

Note You need to log in before you can comment on or make changes to this bug.