Bug 75646 - No colored ls or ll/l. aliases when TERM is ansi
No colored ls or ll/l. aliases when TERM is ansi
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
8.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 12:45 EDT by David Morse
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 10:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Morse 2002-10-10 12:45:51 EDT
Description of Problem: No colored ls, no l. or ll aliases when TERM type is 
set to ansi (which is the default when telnetting in from a Windows box).  This 
is because ansi isn't listed /etc/DIR_COLORS.


Version-Release number of selected component (if applicable): 4.1.9-11


How Reproducible: Every time.


Steps to Reproduce:
1. Telnet to a RH 8.0 box from Windows.
2. ls

Actual Results:  No color when doing ls (also, ll and l. are not set as aliases)


Expected Results:  Color upon ls, ll and l. aliases set


Additional Information:  Quick fix:

--- /etc/DIR_COLORS.orig	2002-10-10 11:30:32.000000000 -0500
+++ /etc/DIR_COLORS	2002-10-10 11:30:43.000000000 -0500
@@ -35,6 +35,7 @@
 TERM vt100
 TERM dtterm
 TERM color_xterm
+TERM ansi
 
 # EIGHTBIT, followed by '1' for on, '0' for off. (8-bit output)
 EIGHTBIT 1
Comment 1 Tim Waugh 2002-10-11 11:41:53 EDT
Thanks.
Comment 2 Tim Waugh 2002-10-22 10:00:24 EDT
Fixed package is 4.1.9-12.

Note You need to log in before you can comment on or make changes to this bug.