Bug 75668 - can't resolve resolvable host names
Summary: can't resolve resolvable host names
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 21:43 UTC by Chris Ricker
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 10:41:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of ncftp (20.90 KB, text/plain)
2002-10-10 21:43 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2002-10-10 21:43:09 UTC
[cricker@peppy cricker]$ ncftp ftp.mozilla.org
NcFTP 3.1.3 (Mar 27, 2002) by Mike Gleason (ncftp@ncftp.com).
Resolving ftp.mozilla.org...                                                    
Unknown host "ftp.mozilla.org".
ncftp> quit
[cricker@peppy cricker]$ strace -f -o ncftp-strace ncftp ftp.mozilla.org
NcFTP 3.1.3 (Mar 27, 2002) by Mike Gleason (ncftp@ncftp.com).
Resolving ftp.mozilla.org...                                                    
Unknown host "ftp.mozilla.org".
ncftp> quit
[cricker@peppy cricker]$ host ftp.mozilla.org
ftp.mozilla.org is an alias for ftp-mozilla.netscape.com.
ftp-mozilla.netscape.com is an alias for ftp-mozilla.gftp-mozilla.netscape.com.
ftp-mozilla.gftp-mozilla.netscape.com has address 64.12.168.243
[cricker@peppy cricker]$ ncftp ftp.mozilla.org
NcFTP 3.1.3 (Mar 27, 2002) by Mike Gleason (ncftp@ncftp.com).
Resolving ftp.mozilla.org...                                                    
Unknown host "ftp.mozilla.org".
ncftp> quit
[cricker@peppy cricker]$ ncftp 64.12.168.243
NcFTP 3.1.3 (Mar 27, 2002) by Mike Gleason (ncftp@ncftp.com).
Connecting to 64.12.168.243(64.12.168.243)...                                   
ftpmoz.newaol.com FTP server (SunOS 5.8) ready.
Logging in...                                                                   
Guest login ok, access restrictions apply.
Logged in to 64.12.168.243.                                                     
ncftp / > 

<snip>

ncftp fails when connecting to ftp.mozilla.org by hostname, even though this
hostname can be resolved.

Attached is the strace -f output

Comment 1 Chris Ricker 2002-10-10 21:43:50 UTC
Created attachment 79864 [details]
strace of ncftp

Comment 2 Mike Bird 2002-11-11 09:37:31 UTC
ncftpget has same problem.  Seems to be switching to IPV6 part way through the
DNS lookup.

Comment 3 Need Real Name 2002-11-18 11:51:02 UTC
it seems fixed in ncftp 3.1.5


Note You need to log in before you can comment on or make changes to this bug.