Bug 75683 - nohide causes exportfs to produce errors
Summary: nohide causes exportfs to produce errors
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-11 01:05 UTC by Stephen Norris
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-11 21:48:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Norris 2002-10-11 01:05:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
Given the /etc/exports:

/var/mnt	ws14.commsecure.com.au(rw,no_root_squash,nohide)
/var	ws14.commsecure.com.au(rw,no_root_squash)

(or in the other order), running exportfs -rv gives:

[root@ws12 root]# exportfs -rv
exporting ws14.commsecure.com.au:/var/mnt
exporting ws14.commsecure.com.au:/var
exporting ws14.commsecure.com.au:/var/mnt to kernel
ws14.commsecure.com.au:/var/mnt: Invalid argument
reexporting ws14.commsecure.com.au:/var to kernel

In this case /var/mnt is NFS mounted from a different server.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put the above in a /etc/exports
2. Run exportfs or restart the nfs service.
3. See the logs.
	

Expected Results:  The /var/mnt filesystem should be exported nohide, and thus a
client mounting /var will be able to see the re-exported /var/mount

Additional info:

This is RH7.3 with all the errata.

Comment 1 Stephen Tweedie 2002-11-11 20:29:38 UTC
What does your /proc/mounts look like at this point?

Comment 2 Stephen Norris 2002-11-11 21:28:29 UTC
On which machine - the client or the server?

Comment 3 Stephen Norris 2002-11-11 21:29:11 UTC
On which machine - the client or the server?

Comment 4 Stephen Tweedie 2002-11-11 21:34:44 UTC
The server --- that's the node which is trying to re-export an NFS mount point.

Comment 5 Stephen Norris 2002-11-11 21:48:10 UTC
I can't seem to reproduce this here, now :(

It still doesn't work properly, but the exportfs command doesn't give errors any
more. I can't use the machine I was originally testing on to confirm, becuase
it's been upgraded to 8.0.

If you can't reproduce it either, you might just have to close it as not
reproducable...

Comment 6 Stephen Tweedie 2002-11-11 21:50:46 UTC
OK.


Note You need to log in before you can comment on or make changes to this bug.