Bug 756864 - Unable to build PDF of document due to corpauthor element?
Unable to build PDF of document due to corpauthor element?
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.7
Unspecified Unspecified
unspecified Severity unspecified
: 3.0
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
: 735687 750245 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 17:15 EST by Stephen Gordon
Modified: 2015-09-27 22:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 23:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log (69.72 KB, text/plain)
2011-11-24 17:15 EST, Stephen Gordon
no flags Details

  None (edit)
Description Stephen Gordon 2011-11-24 17:15:34 EST
Created attachment 536063 [details]
Log

Description of problem:

The Fedora Musician's Guide for F16 contains the following in the Author_Group.xml, no other entries exist:

   <authorgroup>
       <corpauthor>
           Fedora Project Contributors
       </corpauthor>
   </authorgroup>

For reasons unknown this causes all kinds of consternation for FOP when building the PDF from publican, despite this exact tag set building fine in other books. I have attached the log for your amusement.

In the interim I have commented out the xi:include for the Author_Group.xml and the PDF build now works. If you wanted to reproduce I would:

1. git clone git://git.fedorahosted.org/docs/musicians-guide.git
2. Remove the comment markers around the xi:include of Author_Group.xml in Book_Info.xml
3. Attempt to run:

publican build --embedtoc --publish --formats epub,html,html-single,pdf --langs en-US


Version-Release number of selected component (if applicable):

publican-2.8-1.fc16.noarch
publican-fedora-2.0-3.fc15.noarch
fop-1.0-17.fc16.noarch
Comment 1 Jeff Fearn 2011-11-28 20:25:56 EST
Added handling for corpauthor in custom table layout.

Added to branches/publican-2x.

This may be the last fix for FOP ever!

Committed revision 1964.
Comment 2 Jeff Fearn 2011-11-28 20:50:53 EST
*** Bug 735687 has been marked as a duplicate of this bug. ***
Comment 3 Jeff Fearn 2011-11-28 21:21:15 EST
*** Bug 750245 has been marked as a duplicate of this bug. ***
Comment 4 Misha H. Ali 2012-04-22 17:28:47 EDT
Verified PDF local build (publican build) correctly with only the authorgroup element provided in c#1 in the Author_Group.xml file for the book.

Verified on:

OS: Fedora 16
Publican: 3.0
Release designation: publican-3.0-0.fc16.t166.src.rpm

Note You need to log in before you can comment on or make changes to this bug.