Bug 756938 - No menu if searching text in LO with ctrl+F or edit/search
No menu if searching text in LO with ctrl+F or edit/search
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 03:26 EST by Joachim Backes
Modified: 2011-11-25 09:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 09:49:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the original (bgous?) registrymodifications.xcu (1016.03 KB, application/octet-stream)
2011-11-25 08:13 EST, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2011-11-25 03:26:06 EST
Description of problem:
Opening some LO document and trying to search any text fails, because no menu pops up for entering the text to search. No such problem in F15, only in F16

Version-Release number of selected component (if applicable):
3.4.4.2-2.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.open some LO document
2.ctrl+f for searching text
3.
  
Actual results:

No popup menu appears for entering the search text
Expected results:


Additional info:
Comment 1 David Tardon 2011-11-25 03:42:06 EST
Ctrl+F (and the new menu item Edit->Find) now opens search toolbar (by default at the bottom of the screen). The old Find & Replace dialog is accessible through Edit->Find & Replace (like before) or Ctrl+Alt+F.
Comment 2 Joachim Backes 2011-11-25 04:30:01 EST
(In reply to comment #1)
> Ctrl+F (and the new menu item Edit->Find) now opens search toolbar (by default
> at the bottom of the screen). The old Find & Replace dialog is accessible
> through Edit->Find & Replace (like before) or Ctrl+Alt+F.

I updated tentatively to version 3.4.4.2-3.fc16.x86_64 (from updates-testing repo). Then I see the following effects:

1. ctrl+f (edit->find) *does NOTHING, no menu opens, no toolbar opens*, same buggy effect as in version 3.4.4.2-2.fc16.x86_64
2. ctrl+alt+f (edit->find&replace) opens a search/replace menu
Comment 3 David Tardon 2011-11-25 07:02:10 EST
Works fine here, in both English and German locale. It might be a problem in your configuration: could you move ~/.libreoffice/3/user/registrymodifications.xcu away and try again? And if it works after that, could you attach the orignal config. file here?
Comment 4 Joachim Backes 2011-11-25 08:11:02 EST
(In reply to comment #3)
> Works fine here, in both English and German locale. It might be a problem in
> your configuration: could you move
> ~/.libreoffice/3/user/registrymodifications.xcu away and try again?

Indeed, it works after that. I will attach the orinal registrymodifications.xcu
Comment 5 Joachim Backes 2011-11-25 08:13:00 EST
Created attachment 536264 [details]
the original (bgous?) registrymodifications.xcu
Comment 6 Joachim Backes 2011-11-25 08:23:02 EST
Sorry, I forgot to mention that I only was successful after switchting to the English locale; no success with if using the German locale.
Comment 7 Joachim Backes 2011-11-25 09:49:25 EST
After removing some wrong controls, crtl+alt+f and ctrl+f now work flowlessly.

Note You need to log in before you can comment on or make changes to this bug.