Bug 75697 - gnome-terminal crashes upon startup on 8 bpp, vesa driver
Summary: gnome-terminal crashes upon startup on 8 bpp, vesa driver
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte   
(Show other bugs)
Version: 8.0
Hardware: i586
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-11 06:11 UTC by Jaakko R
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 17:41:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaakko R 2002-10-11 06:11:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i586; U;) Gecko/20020809

Description of problem:
If I try to launch gnome-terminal I get a screen:
Application "gnome-terminal" (process 8339) has crashed due to a fatal error
(Segmentation fault)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.8bpp vesa driver
2.launch gnome-terminal
3.
	

Actual Results:  If I try to launch gnome-terminal I get a screen:
Application "gnome-terminal" (process 8339) has crashed due to a fatal error
(Segmentation fault)

Expected Results:  I should get to the prompt.  16 bpp works as expected.

This might be a pango or XFree bug instead of gnome-terminal most likely..

Additional info:

strace gnome-terminal

gets to

open("/home/xxx/.pangox_aliases", O_RDONLY) = -1 ENOENT (No such...
--- SIGSEGV (Segmentation fault)
and a few lines more

Comment 1 Havoc Pennington 2002-10-11 14:38:10 UTC
The screen has a "submit a bug report" button, can you please submit the report
to gnome.org, and then add a comment here with the gnome.org bug number?

Comment 2 Jaakko R 2002-10-11 17:06:13 UTC
gnome.org bug #95525.


Comment 3 Havoc Pennington 2002-10-11 17:40:56 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=95525

I predict it's an Xft problem.

Comment 4 Jaakko R 2002-10-21 16:42:34 UTC
I had a stale version vte lying around...  Works ok.


Note You need to log in before you can comment on or make changes to this bug.