Bug 75699 - Denying access via /etc/hosts.deny causes log flood
Denying access via /etc/hosts.deny causes log flood
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 02:52 EDT by Jordan Russell
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-03 18:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Russell 2002-10-11 02:52:43 EDT
Description of problem:
If access to the sgi_fam service is blocked in /etc/hosts.deny via a line 
similar to this:

   fam: ALL

then attempting to connect to the FAM port via telnet results in a flood of 
messages in syslog:

Oct 11 01:47:09 localhost xinetd[927]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[927]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[928]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[928]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[929]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[929]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[930]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[930]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[931]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[931]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[932]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[932]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[933]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[933]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[934]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[934]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[935]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[935]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[936]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[936]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[937]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[937]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[938]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[938]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[939]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[939]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[940]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[940]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[941]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[941]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[942]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[942]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[943]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[943]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[944]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[944]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[945]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[945]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[946]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[946]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[947]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[947]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[948]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[948]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[949]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[949]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[950]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[950]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[951]: warning: can't get client address: 
Transport endpoint is not connected
Oct 11 01:47:09 localhost xinetd[951]: libwrap refused connection to sgi_fam 
from <no address>
Oct 11 01:47:09 localhost xinetd[812]: Deactivating service sgi_fam due to 
excessive incoming connections.  Restarting in 30 seconds.

Version-Release number of selected component (if applicable):
xinetd-2.3.7-2

How reproducible:
Always

Steps to Reproduce:
(see above)
	

Actual Results:  Flood of log messages. Deactivation of service (note the last 
log entry).

Expected Results:  One log message. No service deactivation.
Comment 1 Bill Nottingham 2002-12-03 15:56:07 EST
Does this behave better with the errata xinetd?
Comment 2 Jordan Russell 2002-12-03 18:41:25 EST
With xinetd-2.3.7-5 I can no longer reproduce the problem.
Comment 3 Bill Nottingham 2002-12-03 19:57:38 EST
Cool. Closing as fixed.

Note You need to log in before you can comment on or make changes to this bug.