Bug 75776 - XMMS stops playing when reaching the end of a song in a playlist
XMMS stops playing when reaching the end of a song in a playlist
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 01:41 EDT by Paul Gear
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 06:47:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gear 2002-10-12 01:41:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
XMMS will not proceed to the next song in a playlist of music files.

Version-Release number of selected component (if applicable):
alsa-driver-0.9.0rc3-fr11
alsa-kernel-0.9.0rc3-fr11_2.4.18_14
alsa-lib-0.9.0rc3-fr3
alsa-utils-0.9.0rc3-fr2
alsa-xmms-0.9.5-fr1
libogg-1.0-1
libvorbis-1.0-1
redhat-config-soundcard-1.0.1-2
vorbis-tools-1.0-1
xmms-1.2.7-13.p
xmms-mp3-1.2.7-13.p
xmms-skins-1.2.7-13.p

How reproducible:
Always

Steps to Reproduce:
1. Cut a CD to OGG format using grip (but doesn't matter - existing files, incl.
MP3 will do)
2. Select the OSS output plugin in XMMS
3. Start a new playlist
4. Add the newly-ripped songs to the playlist
5. Hit play

Actual Results:  First song plays, but that's it.  Need to press the next song
button to get it going again.  This only happens when using the OSS output
plugin.  With the ALSA plugin, it works fine.

Expected Results:  Playlist should play through automatically, without
intervention.  That's the whole point of playlists.  :-)

Additional info:
I have no idea which component this bug is actually in.  For all i know, it
could be the ALSA OSS emulation.  There is no way i can tell, since OSS doesn't
support my sound chipset (via vt8233a) at present.  If bug 54905 is fixed, we
might get further with this...
Comment 1 Shawn Walker 2002-12-17 11:42:03 EST
I'm not using ALSA. Just the standard OSS emu10k1 driver for my Audigy, and it
works a-ok here. I'm guessing it's Alsa OSS emulation.
Comment 2 Paul Gear 2003-01-18 06:47:25 EST
Under kernel-2.4.20-2.9, VT8233 chips are supported, OSS works fine, and XMMS
plays through playlists correctly.

Note You need to log in before you can comment on or make changes to this bug.