Bug 757807 - [abrt] libreoffice-core-3.4.4.2-2.fc16: IsInRange, SfxItemPool::IsItemFlag killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.4.4.2-2.fc16: IsInRange, SfxItemPool::IsItemFlag ki...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:b691c0e4fa9f5a1aef9955081c8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-28 13:34 EST by kotofos
Modified: 2012-06-08 10:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 10:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (25.44 KB, text/plain)
2011-11-28 13:34 EST, kotofos
no flags Details
File: maps (95.29 KB, text/plain)
2011-11-28 13:34 EST, kotofos
no flags Details
File: smolt_data (2.92 KB, text/plain)
2011-11-28 13:34 EST, kotofos
no flags Details
File: backtrace (65.42 KB, text/plain)
2011-11-28 13:35 EST, kotofos
no flags Details
edited document (298.31 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-11-29 12:09 EST, kotofos
no flags Details

  None (edit)
Description kotofos 2011-11-28 13:34:49 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/kotofos/Documents/%D1%82%D1%83%D1%81%D1%83%D1%80%D0%BA%D0%B0/%D1%82%D0%BC%D0%B8%D1%8D%D1%82/%D0%9C%D0%BE%D0%B9%20%D0%BA%D1%83%D1%80%D1%81%D0%BE%D0%B2%D0%BE%D0%B9%20%D0%A2%D0%9C%D0%B8%D0%AD%D0%A2.docx --splash-pipe=7
comment:        too many crtl+z
crash_function: IsInRange
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.1.2-1.fc16.x86_64
pid:            3007
pwd:            /home/kotofos
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Вт. 29 нояб. 2011 01:07:38
uid:            1000
username:       kotofos
xsession_errors: 

backtrace:      Text file, 66988 bytes
dso_list:       Text file, 26050 bytes
maps:           Text file, 97577 bytes
smolt_data:     Text file, 2992 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=kotofos-laptop
:LC_MONETARY=ru_RU.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=2995
:GPG_AGENT_INFO=/tmp/keyring-xqfA1n/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2018-kotofos-laptop-libreoffice-3_TIME2174466
:HISTSIZE=1000
:XDG_SESSION_COOKIE=1ae78454aedfe02bdcbc0f4b00000011-1322499231.340985-1238597161
:GJS_DEBUG_OUTPUT=stderr
:LC_NUMERIC=ru_RU.utf8
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib64/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-xqfA1n
:QTINC=/usr/lib64/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=kotofos
:SSH_AUTH_SOCK=/tmp/keyring-xqfA1n/ssh
:USERNAME=kotofos
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1183,unix/unix:/tmp/.ICE-unix/1183
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/kotofos
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/kotofos/.local/bin:/home/kotofos/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/kotofos
:XMODIFIERS=@im=none
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:LC_MEASUREMENT=ru_RU.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/kotofos
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=kotofos
:QTLIB=/usr/lib64/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-TbgsO6X4aZ,guid=cf6562fb0854846f65103c1c00000021
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/kotofos
:DISPLAY=:0.0
:LC_TIME=ru_RU.utf8
:XAUTHORITY=/var/run/gdm/auth-for-kotofos-mfs4cP/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

var_log_messages:
:Nov 29 01:07:37 kotofos-laptop kernel: [ 4459.344162] soffice.bin[3007] general protection ip:3a81065590 sp:7fffc84a0a48 error:0 in libsvllx.so[3a81000000+10a000]
:Nov 29 01:07:40 kotofos-laptop abrt[3791]: Saved core dump of pid 3007 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2011-11-29-01:07:38-3007 (168108032 bytes)
Comment 1 kotofos 2011-11-28 13:34:54 EST
Created attachment 537597 [details]
File: dso_list
Comment 2 kotofos 2011-11-28 13:34:56 EST
Created attachment 537598 [details]
File: maps
Comment 3 kotofos 2011-11-28 13:34:59 EST
Created attachment 537599 [details]
File: smolt_data
Comment 4 kotofos 2011-11-28 13:35:02 EST
Created attachment 537600 [details]
File: backtrace
Comment 5 Caolan McNamara 2011-11-29 04:39:12 EST
Was this something like "open a .docx and use undo a lot", or where there additional steps. If it was with a specific .docx can you attach that .docx here, or provide some more details that would allow us to reproduce this.
Comment 6 kotofos 2011-11-29 11:59:59 EST
Open .docx, apply style, edit style, ctrl+z, ctrl+z… crash
Comment 7 kotofos 2011-11-29 12:09:58 EST
Created attachment 538122 [details]
edited document
Comment 8 Caolan McNamara 2012-06-08 10:56:42 EDT
I can't reproduce in libreoffice-core-3.4.5.2-15.fc16 by opening the .docx, applying "Complementary Close" to the first paragraph, modifying that style to have a different indent and then ctrl+z repeatedly.

Feel free to reopen if you can still reproduce and give step by step

Note You need to log in before you can comment on or make changes to this bug.