Bug 75790 - xinitrc not automatically selected
xinitrc not automatically selected
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: comps (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 09:59 EDT by Gene Czarcinski
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-12 09:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-10-12 09:59:31 EDT
Description of Problem:

I wanted a system which could run X but not the graphical login so I deselected
gdm and XFree86-xdm.  After the system was installed and I logged on, I did a
startx.  To my surprise, metacity/gnome did not start. After some experimenting
(installing gdm and XFree86-xdm), I found that the missing package was xinitrc.

If XFree86 is installed, xinitrc should be installed by default and not just
when XFree86-xdm is installed.
Comment 1 Tim Powers 2002-11-27 09:35:14 EST
You can install it. xinitrc doesn't have any requirement on XFree86-xdm, or on
gdm. You should be able to select xinitrc in the individual package selection
screen if you wish to install without xdm or gdm.

Tim
Comment 2 Gene Czarcinski 2002-11-27 09:56:01 EST
While I accept this, I believe it would be better to install xinitrc if XFree86
is installed even if none of the *dm packages are installed since it is needed
to run startx properly.

Note You need to log in before you can comment on or make changes to this bug.