Bug 75801 - Cannot compile kernel 2.4.18-14 modules
Cannot compile kernel 2.4.18-14 modules
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 15:17 EDT by David Nečas
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-12 15:35:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
make modules output (both stderr and stdout) (89.93 KB, text/plain)
2002-10-12 15:20 EDT, David Nečas
no flags Details

  None (edit)
Description David Nečas 2002-10-12 15:17:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020921

Description of problem:
Cannot compile kernel 2.4.18-14 modules with default kernel config.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install kernel-source-2.4.18-14.i386.rpm
2. cd /usr/src/linux-2.4
3. make menuconfig
4. don't change anything, exit and save
5. make dep
6. make modules

	

Actual Results:  Compilation fails with an incredible number of errors, the
first occuring here:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.18-14/include -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -pipe
-mpreferred-stack-boundary=2 -march=i686 -DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.18-14/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/3.2/include -DKBUILD_BASENAME=module  -c -o
module.o module.c
In file included from /usr/src/linux-2.4.18-14/include/linux/if.h:23,
                 from cipe.h:21,
                 from module.c:15:
/usr/src/linux-2.4.18-14/include/linux/socket.h:249: invalid suffix on integer
constant
/usr/src/linux-2.4.18-14/include/linux/socket.h:249: parse error before numeric
constant
/usr/src/linux-2.4.18-14/include/linux/socket.h:249:
`memcpy_fromiovec_R_ver_str' declared as function returning a function
/usr/src/linux-2.4.18-14/include/linux/socket.h:249: warning: function
declaration isn't a prototype
.......


Expected Results:  It compiles.

Additional info:
Comment 1 David Nečas 2002-10-12 15:20:34 EDT
Created attachment 80144 [details]
make modules output (both stderr and stdout)
Comment 2 Arjan van de Ven 2002-10-12 15:35:38 EDT
looks like you forgot make mrproper
Comment 3 David Nečas 2002-10-12 17:40:40 EDT
Yes, it seems I forgot make mrproper.  Sorry for a very stupid bugreport.

Note You need to log in before you can comment on or make changes to this bug.