This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 75815 - Apache triggers dial-in on startup
Apache triggers dial-in on startup
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 20:17 EDT by Joerg Mensmann
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 11:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joerg Mensmann 2002-10-12 20:17:17 EDT
From Bugzilla Helper:

Description of problem:
When starting the httpd service, it always tries to resolve the local hostname
using a dns query, and therefore triggers an internet dial-in on my machine.

How reproducible:
Always

Steps to Reproduce:
1. hangup internet connection (or fire up ethereal and watch packets)
2. /sbin/service/httpd restart

Actual Results:  dns query -> dial-in

Expected Results:  nothing

Additional info:

Ethereal shows two dns queries, trying to resolve the local hostname (as shown
by the 'hostname' command). This happens with the default apache configuration
and the hostname set in /etc/hosts. Setting the "ServerName" in httpd.conf made
no difference. Note that this didn't occur on RH 7.3.
Comment 1 Joe Orton 2004-04-05 11:25:44 EDT
This could be a resolver configuration issue: I can't reproduce this
on RHL9 if the server hostname is /etc/hosts.

Note You need to log in before you can comment on or make changes to this bug.