Bug 75827 - Failed dependancies
Summary: Failed dependancies
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-13 11:34 UTC by Paul Johnson
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 23:13:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from rpm -qpR (827 bytes, text/plain)
2003-02-24 23:32 UTC, Paul Johnson
no flags Details

Description Paul Johnson 2002-10-13 11:34:07 UTC
Description of Problem:
When installing a KDE application via add applications, the dependancy libraries
cannot be found even through they exist on the CDs

Version-Release number of selected component (if applicable):


How Reproducible:
Depends on the application, frequent if the user has installed a Gnome desktop

Steps to Reproduce:
1. Get a KDE based application
2. Attempt to install
3. 

Actual Results:
The installer complains that certain libraries are required

Expected Results:
The installer should say to insert Psych 8.0 CDx and install as it does when
installing Opera 6.03

Additional Information:
I have not tested this the other way around (i.e. install a KDE desktop instead
of a Gnome one)

Comment 1 Jeremy Katz 2002-10-31 22:43:38 UTC
What libraries is it looking for?  Note that the KDE libs included in Red Hat
Linux 8.0 are not compatible with those from older releases due to the change in
the C++ library.

Comment 2 Paul Johnson 2002-11-01 23:58:28 UTC
The libraries looked for are always the devel ones, so take your pick.

The really fun part is that if you manually install them, they will still fail
to register when you try to install a KDE package (and more than that, if the
package fails to install due to dependancie problems, but knows the other
packages exist and tries to install them, 9 times out of 10, the installation
will fail, requiring a reset to get the installer to work again - see bug #75825)

Comment 3 Jeremy Katz 2003-02-10 02:08:43 UTC
Can you give the output of 'rpm -qpR package' for one of the packages that won't
install?

Comment 4 Paul Johnson 2003-02-24 23:32:53 UTC
Created attachment 90335 [details]
Output from rpm -qpR

This was generated after the latest release of Wine (Redhat 8 RPM) failed to
install on my laptop. It installed fine on my normal PC.

Comment 5 Jeremy Katz 2003-07-28 23:13:25 UTC
Fixed with newer code


Note You need to log in before you can comment on or make changes to this bug.