Bug 75844 - Draw new cursor theme
Draw new cursor theme
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: GraphicArt, Triaged
: 80310 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-10-13 17:58 EDT by Mike A. Harris
Modified: 2007-04-18 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 02:13:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2002-10-13 17:58:36 EDT
Description of Problem:
When starting X with the "whiteglass" cursor theme by setting:

XCURSOR_THEME=whiteglass startx

The white transparent mouse pointer contains a single pixel wide
vertical strip of missing color about 1/3 of the way from the left
side of the cursor.  It looks as if it might be a glitch in the
actual cursor images, but a glitch in the code isn't ruled out
yet either.

Version-Release number of selected component (if applicable):
4.2.99.1-0.20021008.[0-8] and 4.2.99.1-0.20021012.0

Problem reported to Keith and Jim also.

How Reproducible:
100%.

The system this has been tested on is a Compaq Proliant ML530 with
an ATI Rage IIc onboard video.

Another user has mentioned this problem also.

Any other users experiencing this problem should make a comment below
also, and indicate their hardware, in case it happens to matter at all.
Comment 1 Mike A. Harris 2002-11-03 03:23:42 EST
Problem reported to XFree86.org private development list.
Comment 2 Per Winkvist 2002-11-14 04:04:10 EST
I experienced the same thing with the 4.2.99.2-0.20021105 snapshot.
(NV11 GeForce2 MX, rev 161)
Comment 3 Mike A. Harris 2002-12-19 06:20:14 EST
It's not a software bug, but a graphic bug.  The actual cursors themselves
suck.  I'm removing whiteglass real soon, as it doesn't appear anyone upstream
is interested in fixing this.  I'm told we will be making our own cursors
that don't suck for our final release.

Reassigning to redhat-artwork, as I'm not sure where it fits really, but
XFree86 is losing whiteglass in my next build.
Comment 4 Mike A. Harris 2002-12-25 14:22:35 EST
*** Bug 80310 has been marked as a duplicate of this bug. ***
Comment 5 imorgan 2003-01-07 23:39:03 EST
Ack! Removing whiteglass was such a bad thing. Redglass SUCKS. Since whiteglass
worked just fine for me (no graphic glitches at all), I have put them back in by
hand, but how does one revert to the plain-old X cursors with these new builds
if I don't want the new 'fancy' cursors?
Comment 6 Havoc Pennington 2003-01-08 18:07:17 EST
There's no point debating the merits of whiteglass/redglass, they are just
placeholders to test the icon code. Report bugs if there are any graphics
artifacts or other X bugs.
Comment 7 Mike A. Harris 2003-01-09 06:02:59 EST
imorgan:  No problem.  I've removed redglass now too, so there are no ugly
placeholder cursors.  The next build of X will default to the stock legacy
cursors.
Comment 8 Havoc Pennington 2003-01-09 09:41:16 EST
mharris, we're going to ship with garrett's cursors; you might 
want to get some testing on the new cursor system. Just a thought.
Comment 9 Havoc Pennington 2003-01-17 18:24:36 EST
redhat-artwork now contains a Bluecurve cursor theme. Moving to XFree86 as the
remaining task is for X to default to this theme.

I think the Bluecurve cursors will also still get some tweaking, but 
we will be tweaking that theme rather than switching to another one, 
so XFree should be defaulted to Bluecurve and left that way.
Comment 10 Sammy 2003-01-20 10:56:43 EST
Some of us liked redglass/whiteglass despite its problems for *experts*. I think 
the standard X stuff is ugly and everyone who saw this cursor theme was impressed. 
I put them back in by hand. How about a redhat-config-cursors rpm? 
Comment 11 Mike A. Harris 2003-01-20 21:17:27 EST
redglass and whiteglass are definitely not coming back into the distribution
as they exist right now.  In order for them to come back, a professional
artist needs to volunteer to fix all of the problems in them, including
fixing the graphical glitches in whiteglass, adding cursors that are missing
from whiteglass, and redoing both themes so that the drop shadow is much
much closer to the real cursor, so that people do not go cross eyed.

While some people may "like" one of these two themes, the *tonnes* of
bug reports received by us indicate quite clearly that they are not
shippable to the masses.  An OS should not receive mouse cursor bug
reports due to poor graphic art.

People who want these two works of ugliness will have to install them
by hand from XFree86 source code.
Comment 12 Mike A. Harris 2003-01-21 02:13:58 EST
Xcursor defaults to Bluecurve cursor theme now.  Also, the icon/cursor
themes now default to being placed in /usr/share/icons

Note You need to log in before you can comment on or make changes to this bug.