Bug 75884 - (SCSI AIC7XXX)aic7xxx (adaptec scsi 2842VL) panic during install
(SCSI AIC7XXX)aic7xxx (adaptec scsi 2842VL) panic during install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 11:34 EDT by Brent R Brian
Modified: 2008-08-01 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of kernel oops loading aic7xxx on adaptec 2842 (54.67 KB, image/jpg)
2003-04-15 00:17 EDT, ckulesa
no flags Details

  None (edit)
Description Brent R Brian 2002-10-14 11:34:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; Q312461)

Description of problem:
During install both the aic7xxx and aic7xxx_old panic.  I have tried
recompiling the kernel (install) using the "probe VL ..." and both drivers as 
monolithic, still the panic (same occurs with the FD images from the CD).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make the floppies from CD images boot.img and drvblock.img
2. Boot machine (HD and CD both attached to AHA-2842VL, no IDE)
3. Neither driver (aic7xxx or aic7xxx_old) will work

	

Additional info:

486DX-100, 32M RAM, Trident Video (VLB), Adaptec 2842 (VLB), 2 COM.
Seagate 1G  ID 0
Compaq 4.5G ID 1
CD-ROM      ID 2

The last version of RH to work on this machine was 7.0

I have the same RH8.0 on another machine that I can do kernel builds
on (I have been making monolithic kernels to test both drivers).

Please reply to brent@bmgen.com
Comment 1 Arjan van de Ven 2002-10-14 15:30:27 EDT
RHL 8.0 has pentium as minimum requirement btw
Comment 2 Sergey Leonovich 2002-11-06 02:14:24 EST
I am having similar (?) problem with aic7xxx driver HANGING during
attempted fresh install of RH 8.0
Current system: HP Kayak XW Dual PII-200
SCSI adapter: AHA-3940U
Existing/working installation: RH 7.1, kernel 2.4.16
Symptom: Every time I try to install, after booting from CD, system
says "Loading AIC7xxx driver..." and hangs. Alt-Fx won't do anything
Comment 3 p0pc0rnking 2002-11-13 04:11:26 EST
aic7xxx driver hangs on fresh installation for me also. 
Current system: abit SR7-8X  with 1.6P4
SCSI adapter: AHA-2940UW 
Existing/working installation: RH 7.3, kernel that shipped with it.
Symptom: Every time I try to install, after booting from CD, system
says "Loading AIC7xxx driver..." and hangs.
Comment 4 Sergey Leonovich 2002-11-26 17:30:52 EST
Can RH provide an update when this problem will be fixed please
Comment 5 Justin T. Gibbs 2003-01-10 19:07:22 EST
aic7xxx 6.2.8 had a few aic7770 (EISA/VLB) regressions in it.  These are
believed to be fixed in 6.2.26.  As for the hangs using PCI cards, from
the information provided so far in this bug, it looks like the classic
VIA memory mapped I/O issue.  6.2.26 works around this by falling back to
PIO.  You can avoid the fallback by changing your BIOS to disable the
"PCI Byte Merging" feature (which causes the system to violate the PCI
spec).
Comment 6 Justin T. Gibbs 2003-01-21 19:38:55 EST
Version 6.2.28 of the aic7xxx driver is now available in both DUD and RPM
format for rh8.0.  I would appreciate feedback on whether it fixes any
of the issues mentioned in this bug:

http://people.FreeBSD.org/~gibbs/linux/DUD/aic7xxx
http://people.FreeBSD.org/~gibbs/linux/RPM/aic7xxx
Comment 7 ckulesa 2003-04-12 17:55:06 EDT
Looks like an ongoing problem.  And a long-standing one. 

System:  Pentium Overdrive (83 MHz) on 486 ISA/VLB board with 2 SCSI disks and
CDROM hanging off Adaptec 2842 in VLB slot, 64 MB RAM.

Last install to work:  RH 7.2 
Installs tested and failed :  RH 7.3 (unrelated kernel problem), 8.0 and 9. 

The aix7xxx driver does not hang, but also does not find the host adapter. 
There are no error messages in init_module, but it silently fails:

init_module: [blank line w/ no message]
Hint: insmod errors are usually due to IRQ conflicts, etc.... blah blah

A RH 7.2 boot shows the following:

SCSI subsystem driver Revision: 1.00
(scsi0) <Adaptec AHA-284X SCSI host adapter> found at VLB slot 1
(scsi0) Narrow Channel, SCSI ID=7, 4/255 SCBs
(scsi0) Downloading sequencer code... 415 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5.2.0
       <Adaptec AHA-284X SCSI host adapter>
  Vendor: SONY      Model: CD-ROM CDU-76S    Rev: 1.1c
  Type:   CD-ROM                             ANSI SCSI revision: 02
  Vendor: QUANTUM   Model: FIREBALL1080S     Rev: 1Q08
  Type:   Direct-Access                      ANSI SCSI revision: 02
  Vendor: CONNER    Model: CFP1060S 1.05GB   Rev: 2135
  Type:   Direct-Access                      ANSI SCSI revision: 02
Attached scsi disk sda at scsi0, channel 0, id 4, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 5, lun 0


I have tested Justin's latest 6.2.32 driver disk for Redhat 9 with the same
results.  I'd be happy to test any suggestions, patches or driver disks...
Comment 8 Brent R Brian 2003-04-12 20:35:13 EDT
Using the same driver with AHA-2942 under RH 8.0 with:

   Seagate HD
   HP Scanner C5110A
   CD-ROM

Disk I/O in combination with scanning will lock up system ... have
just loaded RH 9.0, will report back with results ....
Comment 9 Justin T. Gibbs 2003-04-12 21:52:03 EDT
EISA/VLB probing is disabled by default in both the RedHat distributed driver and
the RPMs that I provide on my site.  This is because the VLB probe is an
invasive probe
that can upset some non-EISA, non-VLB, PCI systems.  To enable the probe, you must
hit the EISA/VLB probe toggle:

options aic7xxx aic7xxx=no_probe

You can do this during install by using "linux expert noprobe" and specifying this
option when manually loading the driver.

The "no_probe" name was inherited from Doug Ledford's driver.  I should probably
rename it to something that more explicitly describes what it does.
Comment 10 ckulesa 2003-04-15 00:17:44 EDT
Created attachment 91136 [details]
screenshot of kernel oops loading aic7xxx on adaptec 2842

Thanks Justin, for the hint about aic7xxx=no_probe.  Sadly, it paid no
attention to the module option!  [at RH9 install screen, load module manually
with passed option] Same null response.  

I was able to get it to respond by looking at the patch itself and tried
"aic7xxx=no_probe:0" ... and *that* got a response.  The card was probed and
the devices attached to the 2842 were enumerated.

But the instant the module was loaded, the kernel oopsed and the installer did
not see the enumerated devices.  The installer continued anyway and overwrote
the oops on the screen, so I could not copy it down (no serial terminal, dang).
 

The attachment is a JPG file showing what we can see of the oops.  The PID
responsible was 'loader' (no surprise there I guess).  You can see that
although the oops took place immediately, the aic7xxx driver did manage to
eventually enumerate the devices to the screen.  So it looked alive, and that's
progress in my book! :)

Any ideas about how to proceed, Justin?  I tried the drvblock.img from RH9, and
your 6.2.32 disk image as well, with identical behavior.

I'll gladly test any patches.  I could also build a late-2.4 kernel under the
working RH 7.2 system with aic7xxx-new, and see if I can reproduce a full
kernel oops with it, if it might help. 

Best,
-Craig
Comment 11 Bugzilla owner 2004-09-30 11:40:04 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.