Bug 758875 - There is no way to choose language for the install procedure
Summary: There is no way to choose language for the install procedure
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: David Nalley
QA Contact: Ruediger Landmann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-30 21:09 UTC by Valentin Laskov
Modified: 2012-11-09 14:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-09 14:31:31 UTC
Type: ---


Attachments (Terms of Use)

Description Valentin Laskov 2011-11-30 21:09:03 UTC
Description of problem:
According this discussion [1] in trans mail list, during installation from Live Image, Anaconda must ask for language before dialog for choosing keyboard layout.
At now, to install in Bulgarian, my steps are:
1. Boot from Live Image
2. Select language from Gnome system-settings
3. Logout
4. Login
5. It ask me to rename some directories - Yes, rename them
6. Install on hard disk
7. Select US English keyboard layout
... after installation and login in the newly installed system add Bulgarian keyboard

Version-Release number of selected component (if applicable):
all Fedora Live Image versions

How reproducible:
Try to install in language other than English
 
Additional info: Discussion in trans mail list:
[1] http://lists.fedoraproject.org/pipermail/trans/2011-November/009500.html

Comment 1 Chris Lumens 2011-11-30 21:27:12 UTC
So you're selecting the language from the gnome system-settings thing prior to starting up anaconda?  That's what you are supposed to do.  Is anaconda not being displayed in your chosen language?  Is the installed system being displayed in a language other than the one you chose?

Comment 2 Valentin Laskov 2011-11-30 22:01:58 UTC
Yes, I'm selecting language from gnome system-settings, logout and login for language change to take effect. It ask me to rename user directories Documents, Music, Video, Downloads ... to my language and I agree. All GUI is on my language. Then I'm starting Install to disk.

There is no way to install on my language directly from English GUI. The above procedure is not documented and for some people this may be confusing, I think, about choosing their language during install.

Yes, Anaconda displays all messages on my language.

Yes, installed system is on my language.

Comment 3 Chris Lumens 2011-11-30 22:10:14 UTC
That's the correct work flow as far as the live installer is concerned, though.  If anything's to be done here, it's in the documentation.

Comment 4 Valentin Laskov 2011-12-01 11:56:03 UTC
There was a feature in Fedora 13 and 14 Live Image to change language before login. In Fedora 15 this feature was removed and autologin in English is performed. This makes language changing confusing for new users with no computer and English skills.
Would be better the user can change language without reading documentations before starting Fedora and in Fedora 13 and 14 this feature was very smart and usefull.

Comment 5 Karsten Wade 2011-12-14 03:49:42 UTC
Removing myself for these bug components as I'm either no longer involved in that aspect of the project, or no longer care to watch this particular bug. Sorry if you are caught in a maelstrom of bug changes as a result!

Comment 6 Karel Volný 2012-06-19 08:58:37 UTC
I believe this is duplicate of bug #681750 if you insist on changing system language, or duplicate of RFE bug #829207 if you want to change the installer language directly

either way, I consider this bug superfluous - fixing (even just one of) the abovementioned bugs will resolve this issue

Valentin, please decide your preferred solution and close this

p.s. the shortest workaround seems to be to run from terminal:

export LANG=bg_BG.UTF-8; /usr/bin/liveinst

Comment 7 Valentin Laskov 2012-11-09 14:31:31 UTC
technically, this bug should be closed because Anaconda provides an opportunity for choice of language and keyboard layout (pretty nice! I Like it!) during the installation procedure.
But I did not see a way to try Fedora 18 Alpha Live DVD (without installing) in a language other than English. Should be filled new bug report for this, I think.


Note You need to log in before you can comment on or make changes to this bug.