Bug 758895 - Several yum packages, including selinux-policy, fail to update
Several yum packages, including selinux-policy, fail to update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-30 17:20 EST by Brad Rubenstein
Modified: 2011-12-02 15:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-02 15:45:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brad Rubenstein 2011-11-30 17:20:43 EST
# date
Wed Nov 30 14:08:19 PST 2011
# yum clean all
# yum update selinux-policy
Running Transaction
  Updating   : selinux-policy-3.10.0-61.fc16.noarch                                                                                    1/2 
Error unpacking rpm package selinux-policy-3.10.0-61.fc16.noarch
error: unpacking of archive failed on file /usr/share/man/man8/ftpd_selinux.8.gz;4ed6a8ee: cpio: open
selinux-policy-3.10.0-56.fc16.noarch was supposed to be removed but is not!


Notes:
Last successful update was Tue Nov 29 10:57:12 PST 2011.
After noticing this failure, I turned off presto (by setting minimum_percentage=0), and pointed the fedora-update repository to the baseurl. 
I also did a restorecon -Rv /usr/share/man, all to no effect.  I confirmed that none of my filesystems are full.  What am I forgetting?

A complete update shows the following packages are failing to install (all with a similar error message):
libreoffice-calc-3.4.4.2-3.fc16.i686
libreoffice-core-3.4.4.2-3.fc16.i686
libreoffice-draw-3.4.4.2-3.fc16.i686
libreoffice-graphicfilter-3.4.4.2-3.fc16.i686
libreoffice-impress-3.4.4.2-3.fc16.i686
libreoffice-math-3.4.4.2-3.fc16.i686
libreoffice-pdfimport-3.4.4.2-3.fc16.i686
libreoffice-presenter-screen-3.4.4.2-3.fc16.i686
libreoffice-ure-3.4.4.2-3.fc16.i686
libreoffice-writer-3.4.4.2-3.fc16.i686
gtk2-2.24.8-2.fc16.i686
gtk2-immodule-xim-2.24.8-2.fc16.i686
ibus-m17n-1.3.3-6.fc16.i686
selinux-policy-3.10.0-61.fc16.noarch

I apologize in advance for the categorization.  I'm not sure where to put a suspected build problem bug.
Comment 1 Miroslav Grepl 2011-12-01 04:36:19 EST
Well, what does

# lsattr /usr/share/man/ |grep man8
Comment 2 Brad Rubenstein 2011-12-02 15:45:46 EST
On reboot, the disk was corrupt, and after fsck, the problem was not reproducible.  I am closing this report.

Note You need to log in before you can comment on or make changes to this bug.