Bug 75906 - Click to focus kills selection
Click to focus kills selection
Status: CLOSED DUPLICATE of bug 74825
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 15:55 EDT by Pete Zaitcev
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 18:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2002-10-14 15:55:31 EDT
Description of Problem:

Selection in a window dies if you click in another window.
It stays if you click in the same window. Moving focus with
the panel keeps selection as well.

Version-Release number of selected component (if applicable):

gnome-terminal-2.0.1-5

How Reproducible:

Always

Steps to Reproduce:
0. Run gnome with default click-to-focus setting
1. Open two gnome-terminal windows
2. Select something in one (it will be focused and raised as you select)
3. Click into other window
4. Watch selection disappear. And it is not just unselected, as in xterm,
   but actually disappears: middle button yields no paste.

Actual Results:

Selection is lost.

Expected Results:

Selection kept.

Additional Information:
	
At first it sounds workaroundable, because you can paste "in the blind".
Indeed, to click into a window, a little piece of it must be visible,
but if so, you can middle-button something into it just as easily.
The problem is that before I paste something into a terminal window,
I would like to ensure that the legacy application is actually ready
(e.g. vim is insert mode), and that requires to see whole window.

I do not remember if RH7.3 gnome-terminal was right or not, because
I ran 7.3 with follow-mouse focus. This time I use click-to-focus
because 1) it is the default, and I want to be just like a user,
2) delay to raise in metacity cannot be changed.

xterm works right.
Comment 1 Havoc Pennington 2002-10-14 18:07:56 EDT
This is a dup I believe.

(If you mean autoraise delay in metacity, there is a hidden gconf key for it.)
Comment 2 Pete Zaitcev 2002-10-14 18:23:40 EDT

*** This bug has been marked as a duplicate of 73768 ***
Comment 3 Pete Zaitcev 2002-10-14 18:25:55 EDT

*** This bug has been marked as a duplicate of 74825 ***

Note You need to log in before you can comment on or make changes to this bug.