Bug 75913 - mrtg gives many errors when ran - LANG problem
mrtg gives many errors when ran - LANG problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mrtg (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
: 88747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 17:26 EDT by Dale Lovelace
Modified: 2007-04-18 12:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 17:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Lovelace 2002-10-14 17:26:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; YComp 5.0.0.0)

Description of problem:
mrtg seems to suffer from the "LANG" setting in RH8.0. 
Changing /etc/sysconfig/i18n to LANG="C" allows mrtg to run normally.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type in "mrtg /etc/mrtg/mrtg.cfg"
2. Watch errors fly by
3.
	

Additional info:
Comment 1 Need Real Name 2002-10-17 08:24:46 EDT
I'm having the same error:

Malformed UTF-8 character (unexpected continuation byte 0xa4, with no preceding
start byte) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.
Malformed UTF-8 character (unexpected continuation byte 0xa4, with no preceding
start byte) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.
Malformed UTF-8 character (unexpected continuation byte 0xa4, with no preceding
start byte) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.
Malformed UTF-8 character (unexpected non-continuation byte 0xc6, 1 byte after
start byte 0xe5, expected 3 bytes) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line
248.
Malformed UTF-8 character (unexpected continuation byte 0xa7, with no preceding
start byte) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.
Malformed UTF-8 character (unexpected continuation byte 0xaa, with no preceding
start byte) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.
Malformed UTF-8 character (unexpected non-continuation byte 0x0a, immediately
after start byte 0xcc) at /usr/bin/../lib/mrtg2/locales_mrtg.pm line 248.

etc......


I've tried changing the LANG setting, but still fails.

josh.
Comment 2 Dale Lovelace 2002-10-17 10:29:47 EDT
Did you try 'export LANG="C"' before running mrtg? I think you need to reboot 
before changing the setting in /etc/sysconfig/i18n will take effect. If mrtg 
still gives all the errors try typing 'set | grep LANG' and see what it says.
Comment 3 Need Real Name 2002-10-17 10:34:40 EDT
# export LANG="C"

That did the trick!

Thanks for your help in resolving this.

josh.
Comment 4 Zach Gorman 2003-04-18 14:19:10 EDT
MRTG's cfgmaker also has problems with the RH8/9 LANG setting. It doesn't 
abort, but outputs a corrupt mrtg.cfg file with lots of extra junk in it. 
Changing LANG to "C" also fixes the problem with cfgmaker.
Comment 5 Bishop Clark 2004-03-05 05:02:28 EST
This problem exists in FC1 as well.  I didn't expect that, given the
extensive review process for FC1.
Comment 6 Miloslav Trmač 2004-08-16 17:02:05 EDT
This is not a problem for the default setup using cron because
cron doesn't pass any LANG value.

When mrtg-2.10.5-3 is run from the command line, it prints a
detailed error message if LANG specifies UTF-8.
Comment 7 Miloslav Trmač 2004-08-16 17:04:08 EDT
*** Bug 88747 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.