Bug 75918 - upgrade of partitionless install fails (can't find /etc/fstab)
Summary: upgrade of partitionless install fails (can't find /etc/fstab)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-14 23:35 UTC by Barry K. Nathan
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-14 23:38:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback of attempted partitionless upgrade (42.35 KB, patch)
2002-10-14 23:36 UTC, Barry K. Nathan
no flags Details | Diff

Description Barry K. Nathan 2002-10-14 23:35:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009

Description of problem:
Upgrade of a Red Hat 7.1 partitionless install fails because the installer can't
find /mnt/sysimage/etc/fstab.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Perform a partitionless RHL 7.1 install onto a FAT32 partition.
2. Start up RHL 8.0 disc 1.
3. Follow the prompts. When asked for install type, choose to upgrade an
existing system. Then choose to not customize the packages that are upgraded.

Actual Results:  Old installation is found. Installer mounts the FAT32 partition
(in my case /dev/hda1) to /mnt/sysimage. Installer fails to find
/mnt/sysimage/etc/fstab and produces a traceback (which I will attach to this bug).

Expected Results:  Old installation is found. Installer mounts the FAT32
partition to /mnt/loophost. Installer then does a loopback mount of / to
/mnt/sysimage, and the installation proceeds properly. (This is what Red Hat
7.3's installer does.)

Additional info:

Comment 1 Barry K. Nathan 2002-10-14 23:36:53 UTC
Created attachment 80384 [details]
Anaconda traceback of attempted partitionless upgrade

Comment 2 Jeremy Katz 2002-10-15 14:25:31 UTC
Upgrades of partitionless installs to Red Hat Linux 8.0 are not supported.

Comment 3 Barry K. Nathan 2002-10-15 19:15:24 UTC
Ok. It'd be nice if it failed in a more user-friendly manner, though (a
traceback doesn't make it immediately obvious that upgrades of partitionless
installs are unsupported).


Note You need to log in before you can comment on or make changes to this bug.