Bug 75946 - after installing older version of Red Hat Linux, rhn-applet thinks I need hundreds of updates
after installing older version of Red Hat Linux, rhn-applet thinks I need hun...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 04:00 EDT by Eric Smith
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 05:33:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2002-10-15 04:00:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Upgraded a system from 7.3 to 8.0.  Due to problems with VMware and scanner,
reinstalled 7.3.  Now rhn-applet thinks I need to upgrade hundreds of packages,
rather than just the 7.3 errata

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.  Upgrade a system from 7.3 to 8.0
2.  Register the system with RHN
3.  Install 7.3 on the system
4.  Look at the rhn-applet
	

Actual Results:  rhn-applet wanted me to update hundreds of packages

Expected Results:  rhn-applet should only have wanted me to update the packages
for which 7.3 has errata


Additional info:
Comment 1 Daniel Veillard 2002-11-06 08:52:24 EST
Well, I tried exactly those steps, up to step 3/
Did you do an upgrade or a reinstall ? 
As far as I can tell "downgrading" from 8.0 to 7.3 is not
a suppoted operation, and results in a seriously damaged system.
So if step 3/ is a complete reinstall, this mean you had
to reregister the system in RHN, is that right ?
What channels does the machine appear to be subscribed to ?

Daniel
Comment 2 Daniel Veillard 2002-11-06 12:30:12 EST
Okay I can't reproduce the problem.
I reinstalled the system with Red Hat 7.3, checked on the RHN
website, the system was listed after 2/ as being subscribed to the
8.0 base channel, after 3/ I had to rerun rhn_register since reinstalling
erases the existing configuration setup, and as soon as the registration
process finished, the machine was listed as subscribed to the 7.3 base
channel and had 53 packages to upgrade but that was normal.
I really don't see what happened, unless you provide more input I don't
see a way to reproduce the problem so far.

Daniel
Comment 3 Eric Smith 2002-11-06 15:12:17 EST
Perhaps "downgrading" would result in a "seriously damaged system", but I was
forced to do a complete reinstall of RH7.3 because doing the upgrade from RH7.3
to RH8.0 had *already* resulted in a "seriously damaged system".

After doing a fresh install of RH7.3, I did re-register with RHN.  Since that
didn't work, I re-registered it again.  To this day, it still claims that it
needs hundreds of packages upgraded.

If no solution to this can be found, I will request a refund of the price of my
RHN subscription.
Comment 4 Daniel Veillard 2002-11-06 18:42:39 EST
> doing the upgrade from RH7.3
> to RH8.0 had *already* resulted in a "seriously damaged system".

  Did you bugzilla those ?

> After doing a fresh install of RH7.3, I did re-register with RHN.  Since that
> didn't work,

  So something *else* failed. Can you explain why and how this
did not work ?

> I re-registered it again.  To this day, it still claims that it
> needs hundreds of packages upgraded.

  How did you register it ? With rhn_register ? What channels are
your machine subscribed to ?(you can find it from
https://rhn.redhat.com/network/systemlist/system_list.pxt
and follow the link associated to your system)

Daniel
Comment 5 Daniel Veillard 2002-12-03 11:15:29 EST
It is likely to be a problem of RPM database cache incoherency left
after an upgrade. We have a fix for that which will be propagated in
rhn-applet >= 2.0.4

Daniel
Comment 6 Aleksey Nogin 2003-01-21 02:48:44 EST
It's also the case that rhn-applet does not notice when you change to another
channel.

I just did the following sequence of steps:

1) Install Phoebe 8.0.92 (fully up2date'd) + a few updates (rhn-applet-2.0.7-1).
2) Start rhn-applet 
3) Install redhat-release-8.0.93 from newer Phoebe
4) Run up2date -p

At this point rhn web site knows I am subscribed to the new Phoebe channel and
have a lot of outdated packages. But when I asked rhn-applet to check for
updates, it still showed me that I am fully up2date'd. Only after I restarted
up2date, it realized I had hundreds of updates available. So, one of the issues
is that rhn-applet does not notice when I change channel subscription under it.
Comment 7 Daniel Veillard 2003-01-21 05:33:30 EST
1/ upgrading for beta releases is not supported
2/ upgrading redhat-release as a way to upgrade a machine
   through RHN is also not supported.

If you want to upgrade a machine, only the installer/anaconda
process is supported. What you describe may not have worked,
but it's not supposed to work anyway.
The original bug for that this point out is fixed in Rawhide.
The added is resolved as a WONTFIX !

Daniel

Note You need to log in before you can comment on or make changes to this bug.