Bug 75949 - kudzu finds 1394 host adapters, but not the 1394 drives
kudzu finds 1394 host adapters, but not the 1394 drives
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 04:06 EDT by Eric Smith
Modified: 2014-03-16 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 15:51:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
contents of /proc/bus/ieee1394/devices (3.53 KB, text/plain)
2002-10-20 02:20 EDT, Eric Smith
no flags Details
/proc/scsi/scsi from the same boot - the DVD-ROM on scsi2 is non-1394 (177 bytes, text/plain)
2002-10-20 02:26 EDT, Eric Smith
no flags Details
boot messages imply that SBP2 found the drives (10.93 KB, text/plain)
2002-10-21 01:53 EDT, Eric Smith
no flags Details
lsmod shows sbp2 module is loaded - maybe this is a bug in sbp2 rather than kudzu? (1.25 KB, text/plain)
2002-10-21 01:57 EDT, Eric Smith
no flags Details
If I run the rescan-scsi-bus.sh script, it takes a while, but the drives are found. This suggests once again that the problem might be with kudzu? (1.55 KB, text/plain)
2002-10-21 02:14 EDT, Eric Smith
no flags Details
/proc/scsi/scsi after running rescan-scsi-bus.sh, all devices found (1.10 KB, text/plain)
2002-10-21 02:17 EDT, Eric Smith
no flags Details

  None (edit)
Description Eric Smith 2002-10-15 04:06:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
System has two 1394 host adapters and six drives.  Kudzu finds both host
adapters, but not any of the drives.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Start with a Red Hat Linux 7.3 system.
2.  Set up two 1394 host adapters, and six drives attached to one of the adapters
2.  Upgrade system to Red Hat Linux 8.0


Actual Results:  kudzu detects 1394 host adapters, but not the 1394 drives

Expected Results:  all 1394 drives should have been found and configured

Additional info:

Athlon system with Asus motherboard, Asus 760MPX chip set, running single CPU
only, not SMP (to avoid 1394 SMP crash).  Creative Labs Audigy sound card with
an OHCI 1394 adapter, not connected to any devices.  Generic OHCI 1394 adapter
connected to three Maxtor 1394
external hard drives, two TDK 32/10/40B CD-R drives installed in Granite Digital
1394 cases, and a Pioneer DVR-A03 DVD-R drive also in a Granite Digital 1394 case.
Comment 1 Bill Nottingham 2002-10-15 16:12:55 EDT
What does /proc/bus/ieee1394/devices look like?
Comment 2 Phil Schaffner 2002-10-16 15:19:38 EDT
Similar problem on IBM Thinkpad A21p notebook with OrangeLink FireWire CardBus
PC Card.  The card is recognized when inserted but no devices are found.  Only
device connected in my case is a Pioneer DVR-104 in a FireWire case.  Same
hardware setup works fine with Windows XP dual-boot.  May be connected to the
similar problems with Adaptec aha152x_cs cardbus adapters not seeing external
SCSI drives?

On my system /proc/bus/ieee1394/devices looks like:
Node[00:1023]  GUID[00d0f52004005423]:
  Vendor ID: `Linux OHCI-1394' [0x00004c]
  Capabilities: 0x0083c0
  Bus Options:
    IRMC(0) CMC(1) ISC(1) BMC(0) PMC(0) GEN(0)
    LSPD(2) MAX_REC(1024) CYC_CLK_ACC(0)
  Host Node Status:
    Host Driver     : ohci1394
    Nodes connected : 2
    Nodes active    : 1
    SelfIDs received: 2
    Irm ID          : [63:1023]
    BusMgr ID       : [63:1023]
    In Bus Reset    : no
    Root            : no
    Cycle Master    : no
    IRM             : no
    Bus Manager     : no
Comment 3 Eric Smith 2002-10-20 02:20:23 EDT
Created attachment 81184 [details]
contents of /proc/bus/ieee1394/devices
Comment 4 Eric Smith 2002-10-20 02:24:44 EDT
Sometimes when I boot the devices are claimed by the sbp2 driver, show up in
/proc/scsi/scsi, and work OK.  But most of the time they aren't found, even
though they are listed in /proc/bus/ieee1394/devices.  I just attached a copy of
the latter from my most recent boot, in which the devices were not found by sbp2.

I don't think P.R.Schaffner@LaRC.NASA.gov has the same bug, because in my case
my devices do show up in /proc/bus/ieee1394/devices, but his do not.
Comment 5 Eric Smith 2002-10-20 02:26:26 EDT
Created attachment 81185 [details]
/proc/scsi/scsi from the same boot - the DVD-ROM on scsi2 is non-1394
Comment 6 Bill Nottingham 2002-10-21 00:28:14 EDT
Yeah, I don't think P.R.Schaffner@LaRC.NASA.gov's problem is solvable in kudzu;
if it doesn't show up in the ieee1394 devices file, kudzu is *not* going to see
it (and that's not really fixable.)
Comment 7 Eric Smith 2002-10-21 01:53:28 EDT
Created attachment 81265 [details]
boot messages imply that SBP2 found the drives
Comment 8 Eric Smith 2002-10-21 01:57:11 EDT
Created attachment 81266 [details]
lsmod shows sbp2 module is loaded - maybe this is a bug in sbp2 rather than kudzu?
Comment 9 Eric Smith 2002-10-21 02:14:39 EDT
Created attachment 81267 [details]
If I run the rescan-scsi-bus.sh script, it takes a while, but the drives are found.  This suggests once again that the problem might be with kudzu?
Comment 10 Eric Smith 2002-10-21 02:17:25 EDT
Created attachment 81268 [details]
/proc/scsi/scsi after running rescan-scsi-bus.sh, all devices found
Comment 11 Bill Nottingham 2005-03-29 15:51:21 EST
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

In current code, handling of removable drives is done in HAL with the fstab-sync
program.

Note You need to log in before you can comment on or make changes to this bug.