Bug 75950 - dia's fonts do not display correctly in german localization
dia's fonts do not display correctly in german localization
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dia (Show other bugs)
8.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 04:07 EDT by Marcel Kyas
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 08:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A patch which makes dia work without the urw-aliases package and with LANG=de_DE. (10.61 KB, patch)
2002-10-15 04:10 EDT, Marcel Kyas
no flags Details | Diff

  None (edit)
Description Marcel Kyas 2002-10-15 04:07:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
dia does not use the -urw-* fonts installed with X11 and falls back
to  -adbobe-courier-*.  It is looking for the -adobe-* ones.  If you install the
urw-aliases package from the dia home page, it does not find the fonts, because
the font names are translated.

In UTF-8 encoding every other letter drawn on the screen is blank.  When you
export the file to postscript, text will use half the box.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. export LANG=de_DE.UTF-8
2. start dia
3. draw a UML class diagram
4. save the diagram.
5. export it to post script.

Actual Results:  I get a lot of messages telling me that all fonts needed cannot
be found, every other character of text you enter is a blank on the screen. 
When you export the file to post script, those blanks do not appear, but the
boxes are twice as wide as they ought to.  

Expected Results:  It should have found all the fonts installed, because the
urw-font package is installed.  It also should have rendered the diagram
correctly...

Additional info:

If you set the locale to en_EN (by invoking LANG=en_EN dia) and install the
urw-aliases packages available from the dia faq
<http://www.lysator.liu.se/~alla/dia/faq.html>, dia works as expected.
Comment 1 Marcel Kyas 2002-10-15 04:10:25 EDT
Created attachment 80464 [details]
A patch which makes dia work without the urw-aliases package and with LANG=de_DE.
Comment 2 Havoc Pennington 2002-11-04 15:56:17 EST
We should report this bug upstream on bugzilla.gnome.org as well.
Comment 3 Marcel Kyas 2003-03-20 03:23:27 EST
This bug appears to be fixed in dia-0.91.

Note You need to log in before you can comment on or make changes to this bug.