Bug 759631 - debugging output going to stderr always
debugging output going to stderr always
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks: 759635 769266
  Show dependency treegraph
 
Reported: 2011-12-02 16:21 EST by Mike Burns
Modified: 2016-11-30 19:35 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.5-1.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 759632 759635 (view as bug list)
Environment:
Last Closed: 2012-02-21 01:06:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2011-12-02 16:21:51 EST
Description of problem:
A machine that is not registered but has virt-who installed and running will spawn a stack trace every minute to stderr.

Unable to read certificate, system is not registered or you are not root
1
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 126, in _send
  File "/usr/share/virt-who/virt-who.py", line 104, in checkConnections
  File "/usr/share/virt-who/virt-who.py", line 81, in initSM
SystemExit: 1
Unexcepted error occurs, trying to recover
Unable to read certificate, system is not registered or you are not root
1
Traceback (most recent call last):
  File "/usr/share/virt-who/virt-who.py", line 126, in _send
  File "/usr/share/virt-who/virt-who.py", line 104, in checkConnections
  File "/usr/share/virt-who/virt-who.py", line 81, in initSM
SystemExit: 1
Unable to recover, retry in 60 seconds.

Version-Release number of selected component (if applicable):
virt-who-0.4-1.el5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Stack trace

Expected results:
virt-who either dumps only to a log or silently ignores the error if not registered.  

Additional info:

Found using RHEV-H 5.8.  Simply boot the machine and wait, you'll get the above stack trace every minute.

Traced this to virt-who.py

    # Print debugging output to stderr too
    logger.addHandler(logging.StreamHandler())

this should probably either be removed or indented to only be active if running in debug mode:


diff --git a/virt-who.py b/virt-who.py
index 32be133..9c3a310 100644
--- a/virt-who.py
+++ b/virt-who.py
@@ -194,8 +194,8 @@ if __name__ == '__main__':
         # Enable debugging output to be writen in /var/log
         logger.setLevel(logging.DEBUG)

-    # Print debugging output to stderr too
-    logger.addHandler(logging.StreamHandler())
+        # Print debugging output to stderr too
+        logger.addHandler(logging.StreamHandler())

     env = os.getenv("VIRTWHO_BACKGROUND", "0").strip().lower()
     if env in ["1", "true"]:
Comment 2 Radek Novacek 2011-12-13 09:31:43 EST
This bug should be fixed in virt-who-0.5-1.el5

https://brewweb.devel.redhat.com/taskinfo?taskID=3889752
Comment 6 errata-xmlrpc 2012-02-21 01:06:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0225.html

Note You need to log in before you can comment on or make changes to this bug.