Bug 75965 - German accents don't work
German accents don't work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 05:34 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 02:48:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Latex input file (102 bytes, text/plain)
2002-10-16 07:07 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-10-15 05:34:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
The usage of German accents in tetex produces an error even if the package
\usepackage[latin1]{inputenc} is loaded.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create tex-file including German accents and \usepackage[latin1]{inputenc}
2.latex tex-file
3.Error!!
	

Additional info:
Comment 1 Tim Waugh 2002-10-15 05:46:36 EDT
Please attach the input file you are using. (I expect it's in UTF-8, but want 
to check.)
Comment 2 Need Real Name 2002-10-15 16:10:19 EDT
Input file:

\documentclass{article}

\usepackage[latin1]{inputenc}

\begin{document}
a,"a,d
\end{document}


Log file:

This is TeX, Version 3.14159 (Web2C 7.3.1) (format=latex 2002.8.29)  15 OCT 2002
22:05
**\nonstopmode\input{test.tex}
(test.tex (/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2000/05/19 v1.4b Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo
File: size10.clo 2000/05/19 v1.4b Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
(/usr/share/texmf/tex/latex/base/inputenc.sty
Package: inputenc 2000/07/01 v0.996 Input encoding file 

(/usr/share/texmf/tex/latex/base/latin1.def
File: latin1.def 2000/07/01 v0.996 Input encoding file 
))
No file test.aux.
\openout1 = `test.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 5.
LaTeX Font Info:    ... okay on input line 5.

! LaTeX Error: Command \textcurrency unavailable in encoding OT1.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.6 a,"a,^^c3^^a4
                 
Your command was ignored.
Type  I <command> <return>  to replace it with another command,
or  <return>  to continue without it.

[1

] (test.aux) ) 
Here is how much of TeX's memory you used:
 235 strings out of 20887
 2445 string characters out of 196241
 46134 words of memory out of 350001
 3246 multiletter control sequences out of 10000+15000
 3640 words of font info for 14 fonts, out of 400000 for 1000
 14 hyphenation exceptions out of 10000
 24i,4n,17p,132b,162s stack positions out of 3000i,100n,1500p,50000b,4000s

Output written on test.dvi (1 page, 232 bytes).
Comment 3 Tim Waugh 2002-10-15 17:03:52 EDT
Please actually attach the test file (use 'create a new attachment')---I don't
see the errors you do with that input.
Comment 4 Need Real Name 2002-10-16 07:07:43 EDT
Created attachment 80624 [details]
Latex input file
Comment 5 Tim Waugh 2002-10-16 07:12:56 EDT
[tim@cyberelk tim]$ md5sum test.tex
68874e6cd12884815357b0c3d03887b6  test.tex
[tim@cyberelk tim]$ latex test.tex
This is TeX, Version 3.14159 (Web2C 7.3.1)
(test.tex
LaTeX2e <2000/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, i
talian, nohyphenation, loaded.
(/usr/share/texmf/tex/latex/base/article.cls
Document Class: article 2000/05/19 v1.4b Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size10.clo))
(/usr/share/texmf/tex/latex/base/inputenc.sty
(/usr/share/texmf/tex/latex/base/latin1.def))
No file test.aux.
[1] (test.aux) )
Output written on test.dvi (1 page, 224 bytes).
Transcript written on test.log.

What does:

echo ${TEXINPUTS-(unset)}; locale

say?
Comment 6 Need Real Name 2002-10-16 16:25:13 EDT
josef@localhost josef]$ echo ${TEXINPUTS-(unset)}; locale
(unset)
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
Comment 7 Tim Waugh 2002-10-16 18:46:53 EDT
That's what I have too, and I can't reproduce it.

Is this an upgrade or a fresh installation?  What does 'rpm -V tetex
tetex-latex' say?
Comment 8 Need Real Name 2002-10-17 02:48:16 EDT
I changed the environment variable LANG to en_GB, upgraded the tetex packages
tetex-1.0.7-57.1.i386.rpm and tetex-dvips-1.0.7-57.1.i386.rpm and then the error
went away. Anyway, I'm using a fresh installation of Redhat 8.0 and the keyboard
layout (if that has anything to do with it) is German without dead keys.

I hope this helps.

Comment 9 Tim Waugh 2002-10-17 04:12:14 EDT
If you find a way to make the error start happening again, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.