Bug 75981 - RFE: support cups
RFE: support cups
Status: CLOSED DUPLICATE of bug 60983
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2002-10-15 11:10 EDT by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-15 11:10:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2002-10-15 11:10:39 EDT
Description of Problem:
Currently, the only way to configure cups is via their web interface (or at
least it looks that way).  It appears that RH 8.0 contains all of the needed
stuff to make full use of cups (all of the drivers and not just the minimal ones
that come with basic cups).

This is a request to support configuration of cups via the programs in the
redhat-config-printer package.

Now the following may be a bug:

I switched to using cups from LPRng.  I had a printer configured under LPRng. 
When I configured cups via the web interface, I configured the printer more or
less the same way I had it under LPRng.  I then wondered what would happen if I
tried to use redhat-config-printer to add a printer so I brought it up and added
a printer and did a "apply" to restart.  It said OK, lpd restarted.

I then did lpq -Plp1 but cups said that this was not defined.  /etc/printcap had
the definition but cups did not.

Currently redhat-config-printer should either support cups configuration or it
should say that it does not support cups configuration (and not just look like
everything is OK when it is not).
Comment 1 Tim Waugh 2002-10-15 12:19:54 EDT

*** This bug has been marked as a duplicate of 60983 ***

Note You need to log in before you can comment on or make changes to this bug.