Bug 75998 - Incorrect interpreting proxy autoconfig file
Incorrect interpreting proxy autoconfig file
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 13:09 EDT by petr
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petr 2002-10-15 13:09:04 EDT
Description of Problem:
Mozilla goes via proxy even if it is directed to go direct.

How Reproducible:
Always

Steps to Reproduce:
1. set proxy autoconfig file (see example)
2. try to access page that shall go direct

Our proxy autoconfig file (proxy.pac) looks like:

function FindProxyForURL(url, host) {
        if (isPlainHostName(host))      return "DIRECT";
        // nae adresy pxmmo
        if ( isInNet(host, "62.77.73.0","255.255.255.128") ) return "DIRECT";
        // ostatnm pxes proxy
        return "PROXY ns2.ryston.cz:3128; DIRECT";
}

and even the headers seems to be correct:

HTTP/1.1 200 OK
Date: Tue, 15 Oct 2002 17:05:06 GMT
Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux) mod_ssl/2.8.11 OpenSSL/0.9.6b
PHP/3.0.18
Last-Modified: Fri, 19 Apr 2002 14:18:30 GMT
ETag: "203087-fc-3cc02736"
Accept-Ranges: bytes
Content-Length: 252
Connection: close
Content-Type: application/x-ns-proxy-autoconfig

If I enter url http://test.ryston.cz/ which resolves to 62.77.73.65, mozilla
goes via proxy, not directly as expected.

We use the same autoconfig file for long time, it works correctly with all
verisons of Netscape 4.xx, IE5.x, 6.x, Mozilla 0.9.x, 1.0.x, 1.1, 1.2b on
Windows platform.
Comment 1 Bill Nottingham 2006-08-07 14:51:11 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 12:13:49 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.