Bug 76029 - /var/mail mount causes problems
/var/mail mount causes problems
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
1
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
triage|leonardjo|closed|notabug
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 17:57 EDT by Petri T. Koistinen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-17 17:00:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri T. Koistinen 2002-10-15 17:57:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-14 i686)

Description of problem:
[root@linuxtest pkoistin]# /usr/sbin/up2date -u
[...]
xinetd-2.3.9-0.73.i386.rpm: ########################## Done.                   
filesystem-2.1.6-2.noarch.r ########################## Done.                   
Preparing...                ########################################### [100%]

Installing...
   1:filesystem             error: unpacking of archive failed on file
/var/mail: cpio: rename failed - Is a directory
There was a fatal RPM install error. The message was:
There was a rpm unpack error  installing the package: filesystem-2.1.6-2
[root@linuxtest var]# df -H
Filesystem            Size  Used Avail Use% Mounted on
/dev/ida/c0d0p2        15G  6.7G  7.6G  47% /
/dev/ida/c0d0p1        48M   15M   31M  33% /boot
/dev/ida/c0d1p2        32G   25G  6.0G  80% /home
none                   65M     0   64M   0% /dev/shm
/dev/ida/c0d0p3       720M   17M  666M   3% /tmp
/dev/ida/c0d1p1       4.1G   34M  3.8G   1% /var/mail
[root@linuxtest var]# 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/up2date -u
	

Additional info:
Comment 1 Bill Nottingham 2002-10-16 15:46:04 EDT

*** This bug has been marked as a duplicate of 75343 ***
Comment 2 Petri T. Koistinen 2002-10-19 13:42:33 EDT
This is rpm bug.
Comment 3 Leonard den Ottolander 2004-04-17 17:00:07 EDT
/var/mail is a symlink to /var/spool/mail. If you mount a file system
under /var/mail instead of /var/spool/mail of course the copying of
the symlink will fail.

Closing NOTABUG. (Not sure what happened with comment #1 ...)

Note You need to log in before you can comment on or make changes to this bug.