Bug 76041 - Installer crashes at 100% completion
Installer crashes at 100% completion
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-15 21:10 EDT by Keith Boone
Modified: 2007-04-18 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-31 05:43:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith Boone 2002-10-15 21:10:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
Installation always crashes at 100% with error message:
(anaconda:88) GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142
(Gnome_canvas_path_def_any_closed): assertation `path !=NULL' failed
install exited abnormally, sending termination signals ...etc

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install in graphical mode, workstation
2.Install in graphical mode, custom, everything
3.Install in text mode, workstation
4.Install in text mode, custom, everything
LILO selected in all above cases
Tried using Maxtor 60 GB ide drive, and Maxtor 20 GB ide drive
	

Actual Results:  Same result, crash at 100% in every case after at least 6 attempts

Expected Results:  Successful install was expected.  This machine works properly
with
Windows 2000, Windows XP, RedHat 7.2, RedHat 7.3, Mandrake 9.0

Additional info:

P4 2.2 Ghz, Asus P4S533  motherboard, 512 MB ddr ram, Nvidia video,
Soundblaster Live card, Maxtor 60 GB ide 7200 rpm drive, ne2k-pci

Media tests OK, and succesfull install on another machine using same media
Comment 1 Need Real Name 2002-10-16 04:32:00 EDT
I have the same problem
My hardware consists of the same mainboard and same processor,same amount and
type of memory,same hd.
The strange part about it is that redhat 7.3 which has always installed fine for
me,now experiences the same problem as 8.0.
I don't know if this has anything to do with it but i discovered that altough i
am able to read and write to my floppy-drive,i am unable to boot from it.(and
yes bios-settings are fine:-)).
The problem with anaconda exist with every possible type of install.(I just
spend 4 days trying everything my puny mind could come up with.
Comment 2 Keith Boone 2002-10-16 18:30:45 EDT
Actually, now that you mention it sveke, I can't install RedHat 7.3
anymore either.  Very weird.  It installed before, but now it won't.
As mentioned above, other OS's install fine - I'm currently running
Mandrake 9.0, and I did try RedHat 7.2 for a while _after_ having
the problem with 8.0
Comment 3 Need Real Name 2002-10-16 19:12:02 EDT
I too have the same problem. My first reaction was that I was doing something 
wrong, being a newcomer to Linux.

My machine has a different configuration:

- AMD 1.8 Ghz
- PCChips M810 Mainboard (SiS 730 Graphics Chipset, AC97 Sound and 10/100 
Ethernet integrated on mainboard)
- 256MB RAM
- 40GB HD IDE 7200rpm

I accepted all of RH8.0's suggested settings (including auto partitioning)
Comment 4 Need Real Name 2002-10-16 23:23:43 EDT
Here is another report, in the comp.os.linux.redhat newsgroup, by someone else 
of the same problem:

I'm installing Redhat 8 and everything goes OK untill the final stage
of install when all packages have been installed and the dialog "Post
install configuration" comes up and the progress bar reaches %75 and
then the install crashes and I get this error:

(anaconda:83): GnomeCanvas- CRITICAL **:file gnome_canvas_path_def.c:
line 1142
(gnome_canvas_path_def_closed): assertion 'path !=NULL' failed

I have an athlon XP 1600+ and a GEforce 4 MX440 and I tried all
install configurations (minimal, workstation, personal, full), I even
enabled LBA for boot loader, and they all crash at the end.  I'm
installing this on a 60GHD: partition 1 is Win. XP (40 G) and Redhat
on the last 20 G.

See: http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-
8&frame=right&th=5a2d49108c126bd6&seekm=66db9ae7.0210080109.1a18ad33%
40posting.google.com
Comment 5 Need Real Name 2002-10-17 11:03:05 EDT
I have the very same problem. Very annoying. Impossible to do a proper install,
it just bails out. When booting from cd afterwards and doing a rescue boot, I
can create a bootdisk, but when I boot the system with it, no installation
settings are retained (blanco root passwd, no /etc/sysconfig/network, wrong
keyboard layout, kudzu find all new hardware, etc...).

As such, RedHat 8.0 is a no-go here :-\
Comment 6 Need Real Name 2002-10-17 12:30:14 EDT
Sorry for the late reply,I found the solution for my problem yesterday

I just flashed my mainboard BIOS,it worked like a charm,
RH 8.0 installed from the first time,my floppy works normal again:-)

Hope this helps

Greetz
Comment 7 Keith Boone 2002-10-17 23:23:31 EDT
Flashing Bios did not help me.  Tried that already.
Comment 8 Michael Fulbright 2002-10-23 16:17:39 EDT
Since flashing the BIOS addresses the original reporters issues I'm closing this
bug.

If other people have issues to report please open a separate report.
Comment 9 Need Real Name 2002-10-24 13:29:42 EDT
Am I missing something here?

######################################################

Opened by kboone@rogers.com on 2002-10-15 21:10:57

######################################################

Additional comment by kboone@rogers.com on 2002-10-17 23:23:31

Flashing Bios did not help me.  Tried that already.

######################################################

As you can see the original poster still has the same problem after flashing the
BIOS. And so do I, and some others as well:

http://groups.google.com/groups?hl=en&lr=&ie=ISO-8859-1&safe=off&q=gnome-canvas-path-def.c&btnG=Google+Search
Comment 10 Keith Boone 2002-10-24 18:25:18 EDT
I am the original poster, and my problem is _not_ solved.  Why was this
case closed so abruptly?
Comment 11 Keith Boone 2002-10-24 18:43:30 EDT
I am still finding more people with the same problem posting on
usenet on a daily basis.  I recently installed on a horrible old
"emachine" 300 mhz cyrix machine from the same media as used on
my main machine - see details of hardware in the initial message.
The install worked on the emachine.  My point is that my asus p4s533
mb with 2.2Ghz p4 is reasonably up to date hardware, and after
flashing the bios the install still fails in exactly the same way.
Please help.  Thanks.
Comment 12 Need Real Name 2002-10-25 15:33:09 EDT
Hi.  I'm getting the same error, but not on installation.  I did see the error
at the end of my install, but the installation completed ok.  I get this (100%
repeatable) when I try to run hwbrowser (hardware browser) on my IBM Thinkpad
A30p. (Model# 2635-65U)  You can plug this into IBM.COM to get the detailed
hardware specs.  Here's the output from hwbrowser:

[root@els root]# hwbrowser

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

(DeviceList.py:7796): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: lin
e 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed
Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_lis
t
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20
Comment 13 Michael Fulbright 2002-10-30 17:47:44 EST
This sounds like a hw issue.
Comment 14 Keith Boone 2002-10-30 18:43:56 EST
What sort of hardware issue allows Redhat 7.2, RH 7.3, Mandrake 9.0,
FreeBSD 4.7, Slackware 8.1, Debian Woody, Windows 98, 2000, and XP to
install and run properly on this machine but _not_ redhat 8.0???

Yes I have had all of these other OS's on this machine (one at a time).

I have found my own solution:  install RedHat 7.3, then upgrade to 8.0
This works.  A simple install of 8.0 however does not work, and I have
found this to be 100% repeatable.  NOT a hw issue. Has to be a bug in
the installer.
Comment 15 Need Real Name 2002-10-31 05:43:15 EST
This sounds like "please leave us the fuck alone with your annoying problems and
let us PLEASE close this bug!"...
Comment 16 Michael Fulbright 2002-10-31 15:27:24 EST
Intermitent problems of this type are not unusual when hw is the issue.  Given
the wide range of PC style hardware available it is not surprising these issues
arise occasionally.

If there are concerns with the product you purchased you can contact customer
care about a refund.
Comment 17 Need Real Name 2002-11-01 04:42:58 EST
And I thought that M$ support sucked...
Comment 18 deaston 2002-11-01 14:32:50 EST
I am also seeing this problem. 

Hardware:
Gigabyte BA-686BX
512MB
PIII-1GHz
Western Digital 10GB

I think Redhat is making a serious mistake about dismissing this bug as an 
isolated hardware issue.  Take all of the following into consideration and you 
will see why:

I've been working on getting Redhat installed for about 2 weeks now.  I must 
have run the installation 40 times.  It took me until last night to finally 
figure out what was going wrong.  At first I thought it was just a problem 
with my harddrive.  I would run the install, it would "appear" to finish, then 
it would pop the CD out and the last message says something like "It is now 
safe to shutdown your system."  Of course, a typical user looks at that and 
says "Sweet, RH8 is ready to roll".  Reboot and you get a variety of 
behaviors, but usually something like "No operating system found" (other 
people have reported the dreaded "LI" and a few other things.  I can't even 
remember all the different behaviors I got).  

"Hmmm... must be a harddrive problem" I say, so time to figure out how to make 
it boot (boot disks, rescue mode, install grub/lilo manually, etc.)  I'll 
admit that this took me a LONG time mainly because I'm a total newbie to 
linux, but that's just part of my point...   

So I finally get it to boot (many days later), and then I realize that nothing 
is configured.  No root password, no additional users specified during the 
install, no hardware drivers, etc, etc, etc.  So I finally (after more days of 
looking into this) realize that it was actually a problem with the install 
failing.  OK.. go back to the install and re run it for the 51st or so time 
(hey, it only takes 30 minutes...).  FINALLY!  I see the error "GnomeCanvas-
CRITICAL blah, blah, blah", search on it, and find this posting.  

My Point:  Redhat says that this is an isolated hardware incident.  They base 
this on the limited number of reports (I've actually seen about 30-40 posts on 
usenet and other forums).  But how many people actually spend the time and 
effort, and have the knowledge to figure out what is going on in the first 
place.  I consider myself fairly tenacious when it comes to computers.  I 
would estimate that only about 10% of the linux users out there have the 
skills and patience to even bother to figure out what is going on.  Then 
consider how many people out there may have seen the problem but haven't 
bothered to report it.  

I think its a mistake not to consider this a serious problem and at least do 
some research to find out what is going on.  Perhaps it is just a hardware 
issue, but if so, it certainly seems widespread.  I have seen very few counter 
posts on this topic like "Hey, it works fine for me."  Usually its just 
more "Me Too"s and the like.
Comment 19 Need Real Name 2002-11-01 16:07:10 EST
Very well said indeed... A lot of people have this same problem, but hey, it's a
hardware issue. I happen to own a very recent computer that runs smoothly with
every single Operating System I put on there, except RedHat 8.0. But hey, it's a
hardware issue. My PC never freezes or acts funny, even tough I work a lot in
Windows 2000. But hey, it's a hardware issue! Lots of people experience the same
problem. But hey, it's a hardware issue! Someone installed like 10 different
Operating Systems and all worked except RedHat 8.0. But hey, it's a hardware
issue! He even succeeded in upgrading to RedHat 8.0 and running OK. How in the
name of God can it be a hardware issue then?

Well, I just don't buy that. Before the job I'm doing now I worked in an IT call
center. Well, if I would have closed calls/reports with the same arrogance as
how this bug report was treated, I'd be flamed like hell by my boss.

These days I work in a more responsable job. A job where I get to pick what
hardware and software we buy for our server park. Well, I can tell you right now
that RedHat 8.0 will NOT be an option. Not only because it's not stable. Any
operating system has got little buggies, you just have to deal with that. No,
mainly because when you have a problem, RedHat just tells you to take a hike. Oh
did you pay for our software? Well, then you can get a refund. Actually fixing
the problem? Nah, don't feel like it. Nice policy. Even M$ tends to fix bugs
that get reported...

I thought that reports like this deserve better. You didn't even bother to look
into it. I never saw a request from RedHat for futher info, things to check, log
files to send over. Zilch. But hey, it's a hardware issue!
Comment 20 Dag Wieers 2002-11-01 22:43:11 EST
Guys,

The "GnomeCanvas-CRITICAL" error message is NOT related to the problem you are
reporting. In fact, it is possible to see those messages even when having a
succesfull install. That's one of the indications that, although you might think
it is the same problem, it is NOT.

I have seen this case reported with the same symptoms what afterwards was a
kernel-problem with specific HW. So I agree that, unless there is more evidence
to what exactly causes this problem, the problem is closed here, you can always
re-open it if you have more to report. (Complaining about this is not
constructive and will not help in any way).

Comparing Microsoft support with Red Hat's bugzilla is not really fair. This
database is helping a lot of people all the time and this small incident (where
it is inconclussive where exactly the problem lies) should not render
_everything_ useless.

Besides, if you have paid for your distribution, I suggest you contact Red Hat
Customer Care and mention this bugreport, as one of the QA people suggested and
complain there about the product. If you haven't paid for the product, you may
as well be thankful that you have the opportunity to ventilate your problem here.

So please be constructive and re-open the bug if you have more to report that
may help pinpoint the problem.

BTW it might be very helpful to look in the source of the Anaconda installer to
see what the installer does when all packages are installed. Something there is
obviously stressing hardware or causing something to fail.

Good luck.
Comment 21 deaston 2002-11-02 00:29:45 EST
The previous poster makes some good points.  I would like to find a resolution 
as I really want to get Redhat working, so we should focus our energies on 
solving the problem.

I'm curious to know more specifics on the previous poster's experience with 
this problem.  You mention that you don't think this is related to the 
GnomeCanvas error.  Can you elaborate?  Maybe it will point us in the right 
direction.

Also, I've seen some other posts on this topic where peopled reported luck by 
changing BIOS settings, removing USB devices, and a few other ideas.  I'd love 
to try those, but running this install takes so much time that testing it may 
take forever.  Any ideas on a way to run the install in a way that will dupe 
this problem, yet finish quickly?  Obviously I can run the minimal install and 
see what happens, but is there an "automated" or "unattended" mode I can run 
the install in?

Thanks.
Comment 22 Dag Wieers 2002-11-02 01:06:35 EST
To be clear, I don't experience this problem myself. bever@phreaker.net
mentioned this bugreport on IRC and I don't agree with his take on the issue.
I've been looking at the different reports (mentioned here and on usenet) and
what stroke me was that, although they all mention that at 100% it crashes, some
seem to indicate they are not related.

The fact that some can solve it by changing BIOS settings, some report that the
kernel mentions a BUG() (before bailing out) and because people that said RH 7.3
used to work, but since they noticed the problem RH 7.3 doesn't work anymore,
makes me agree with the msf@redhat.com that there is no indication that this is
a _real_ bug in Anaconda. It may be HW, it may be the kernel and maybe it is
Anaconda. There simply is no proof.

Let me elaborate on that. First of all, the GnomeCanvas-CRITICAL messages I have
seen before with applications that worked perfectly. These are debug messages in
GnomeCanvas and indicate a problem that is critical to GnomeCanvas (not
necessarily for the application). I think you get these if there are
rendering-errors, but as I said they are not necessarily fatal to the application.

The assertion that it is not a HW issue because other operating systems work
well with the HW is flawed. The RH 8.0 installation uses a kernel that is not
used by any of the other OS's and it is not the same installation process as RH
7.3. I can imagine a problem in the new RH 8.0 Anaconda installation process
that triggers faulty HW. This is not necessarily Anaconda's fault and working
around this problem in Anaconda is the wrong approach anyhow. The kernel/drivers
should be fixed in this case.

But as long as we cannot pinpoint the exact problem and as long as it occurs to
a few people, I think Red Hat cannot do anything except closing the bug-report
until they have new evidence that it, in fact, is a problem with Red Hat they
can fix. It is up to you, not to Red Hat. (This of course is not the case when
you actually bought the product, that's why you should contact Customer Care IMO)

This may be very frustrating to people who cannot get Red Hat 8.0 to install.
And I think Red Hat should be happy that people get emotional when they cannot
install their product ;-)

Remember that bugreports that are still open but don't have a clear resolution
and little information (like this one) will make the QA people loose their focus
on other bugreports that have a clear resolution. And if you re-open it with new
information, you will regain that focus with much more result and co-operation
of the people that it was assigned to.
Comment 23 Dag Wieers 2002-11-02 01:22:54 EST
Having said that, here are some things you can do to pinpoint the problem.

* Make sure you can do reinstalls easily and fast. You could create a kickstart
file with only the basic packages and use that to install.

* Because the GnomeCanvas-CRITICAL is not related (and to prove this to you) try
to install using text-mode. This way you don't use GnomeCanvas and therefor if
it still bails out if it is unrelated ;-))

* You could debug the problem by elimination. I still think the installation
triggers a HW problem. (Not neccesarily a HW fault in se, could be the kernel)
So by removing devices from your system (or better start with a minimal system)
and removing (or adding) devices. And everytime reinstall the system. (The same
goes for BIOS settings, disable everything that uses IRQ's or system resources
at first)

* What exactly is the last package that was installed before the installation
bails out ? What is in the post-scripts of that package that may cause the
problem ? (rpm -qp --scripts <package>)

* If Anaconda triggers the HW problem, check what Anaconda exactly does when it
has installed all the packages. Maybe it first does some default things before
showing another screen.

Don't expect that Red Hat is responsible to help you with this if you haven't
bought the product (if you have, go to Customer Care). Red Hat is there to help
you if you have specific problems they can solve. In a case like this, they
can't do a lot. The installation wasn't succesful so there's not much to ask you
to do. And it could even be a combination of several problems that lead to this.

Also remember that Anaconda expects everything in a certain way, if something
unexpected happens it normally will give you a screen so you have the
opportunity to put debugging info on a floppy. Since this is not the case, it
seems that Anaconda didn't even have the opportunity to do so. That's one of the
reasons, I guess, why msf@redhat.com holds on to HW issues (and I tend to agree).
Comment 24 Need Real Name 2002-11-02 04:44:33 EST
I find it very noble of Dag to support the way RedHat deals with this. Normally
we stand side by side on IRC in the numurous Debian versus RedHat distrowars.
However, on this one we just disagree :-)

I don't want to end up in endless discussions here. I just got a few questions
that I would like to get answered:

1) How do you hold on to it being a hardware issue, when every other OS installs
fine. Even more: RedHat 8.0 runs fine when doing an upgrade from 7.3 as well. So
every OS runs OK, only one can not get installed the normal way. Why is this a
hardware problem then?

2) What is the use of opening a bug report when it is closed before it is solved?

3) Why do you have to debug a product only when paying customers report a bug? I
for one can become a paying customer when I decide we will use RedHat 8.0 in our
server park. So whether I payed for the product now, to me is totally
irrelevant. Besides, msf@redhat.com only talks about a refund when having bought
the package, nothing else.

Can someone give me a clear answer on these three questions?
Comment 25 Dag Wieers 2002-11-02 05:31:48 EST
Instead of arguing like this (which isn't very helpful) I'd rather have you to
go and try one of my suggestions. You wanted suggestions, now do something with
it and report any progress or reopen another bug-report.

Here are my answers (and I'm in no way related to Red Hat):

1) The fact that other OS's run fine on the same HW doesn't exclude it to be a
HW-centered problem. As I said, there are several indications that, although the
symptoms seems the same, the problem is not. This makes it harder to resolve the
issue(s), let alone find the problem.

 + For some the problem is fixed by flashing the BIOS or changing settings
 + Some reports mention a kernel BUG()
 + For some people it happens at 75%, others 100% (and probably at various other
stages as well)
 + Where Anaconda normally allows you to save debugging info to floppy, this is
not the case here, so more likely to be a specific HW problem.

And since YOU are the only person that can debug the problem (because we don't
have that problem) it is up to you.

BTW Upgrading from RH 7.3 to Red Hat 8.0 is in no way comparable to following
the installation process. I don't understand why you use that to argue that it
is not a HW problem.


2) You seem to say that EVERY bugreport is closed before it is solved. This is
simply not the case. By using statements like this you are offending the people
that you want help from. Please don't generalize like that. It won't help your
case anyhow and makes me want to stop helping you. (This is my personal time you
are consuming here)


3) The same as 2). You're implying that your case is the default case and that
is in direct contrast to my experience with Red Hat. Offensive.

Besides, if you're not paying for support now. Why would you pay for support
later, if you get the support for free now ? I'm not saying that you won't get
any support here, but that logic doesn't make sense. You should be happy for
what you get for free, everything more than that (as a non-paying customer) is a
bonus.

Please, try one of the many suggestions I gave you and stop complaining. If you
think that using another distribution will benefit your company, more power to
you ! If you demand support, buy support! If you don't want problems installing
Red Hat, buy a Red Hat certified or Red Hat pre-installed machine.

Just don't demand that people help you for free. See if Microsoft support falls
in that trap ;)
Comment 26 Need Real Name 2002-11-02 06:26:47 EST
1) "BTW Upgrading from RH 7.3 to Red Hat 8.0 is in no way comparable to following
the installation process. I don't understand why you use that to argue that it
is not a HW problem."

That is just my point! The operating system does not refuse to operate as one
might expect from a hardware problem, it just fails to install. If you do an
upgrade, it does run fine. So one might expect that the problem is the installer
then, no?

2) Where exactly did a make a statement like that? Could you copy/paste? And
where exactly did I ask for your personal time to be consumed by me?

3) A copy/paste here would be nice as well.

Why would I pay for support later? Well, that's the way we work. We buy a
server, including OS and a 7/7 24/24 support contract. But I find it good
practice to try out the product first and then buy it for our company. Is that
so strange?

Anyway, as far as I am concerned this case is closed. I too am putting in my
personal time for this, and quite frankly, I can do waste it on far more useful
things than to bang my head against a brick wall. 

After all, the bugreport is closed as well, so why do we still bother?
Comment 27 Dag Wieers 2002-11-02 06:52:03 EST
1) Sure, the installer probably triggers a HW problem. Could be a package that
does something, a module that gets loaded, something used for the first time.
That's part of the installation process. I'm not saying it isn't related to the
installer, did I ? I think it is HW related, that's all. Fine if you don't
agree, but either come up with some proof (prove us wrong!) or stop arguing.


2) By not doing what I ask and arguing about words you're using my personal time
instead of helping to resolve the issue.


3) Sure, you can test the product for free, but you cannot test the support for
free ;) That's not included for free. Luckily, you can use bugzilla, but that is
in no way comparable to paid support.


It's not because THIS bugreport is closed that you should stop trying to resolve
the problem. (I gave you some hints, but you don't want to help, instead you
argue) I don't understand your reasoning.

Apparently you don't want the issue to be resolved. Fine by me, but don't
complain and blame others for something only you can resolve.


PS deaston@inquisite.com, if I read your bugreport, it is not related to this
one. In fact, your installation ends succesfully and does not crash.
Comment 28 Need Real Name 2002-11-02 08:48:12 EST
* Because the GnomeCanvas-CRITICAL is not related (and to prove this to you) try
to install using text-mode. This way you don't use GnomeCanvas and therefor if
it still bails out if it is unrelated ;-))

Been there, done that. Bails out as well.

* You could debug the problem by elimination. I still think the installation
triggers a HW problem. (Not neccesarily a HW fault in se, could be the kernel)
So by removing devices from your system (or better start with a minimal system)
and removing (or adding) devices. And everytime reinstall the system. (The same
goes for BIOS settings, disable everything that uses IRQ's or system resources
at first)

I'm sorry, but I do not have the time to take my PC apart again and gradually
adding hardware until the install fails.

* What exactly is the last package that was installed before the installation
bails out ? What is in the post-scripts of that package that may cause the
problem ? (rpm -qp --scripts <package>)

Depends on what extra packages you select. The extra packages are on CD3 and are
installed at the end. I had the same problem with and without installing extra
packages, so the last package was different.

* If Anaconda triggers the HW problem, check what Anaconda exactly does when it
has installed all the packages. Maybe it first does some default things before
showing another screen.

And how do you do that?

"PS deaston@inquisite.com, if I read your bugreport, it is not related to this
one. In fact, your installation ends succesfully and does not crash."

He said it _appeared_ to have finished OK, but when taking a closer look, it id
not. That's what I had too. The actual installation of all packages runs fine. I
guess the problem arrises when the installer starts configuring your
configuration, that it bails out. Just like deaston@inquisite.com, no settings
that were entered during install were saved. We both have the very same problem
on _totally_ different hardware configurations. 

My hardware config:

Pentium IV 2.26
Asus P4S533 motherboard
512 MB DDR333 RAM
Western Digital 120 GB WD1200JB
Maxtor 40 GB 54098U8
Hercules Radeon 8500 LE 128 MB
Comment 29 Keith Boone 2002-11-02 14:16:56 EST
Replies to some of dag's remarks - I am the original poster

* Because the GnomeCanvas-CRITICAL is not related (and to prove this to you) try
to install using text-mode. This way you don't use GnomeCanvas and therefor if
it still bails out if it is unrelated ;-))

When I do a text mode install it fails at the same place (after installing the
last package) and fails with the _same_ messages : 
(anaconda:88) GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c: line 1142

BTW - it doesn't matter which packages you select, I've tried many different
configurations ranging from KDE only, gnome only, all pacakages, no X comonents
at all, and it ALWAYS fails after installing whatever the final package is, and
it always gives the same message.

*1) The fact that other OS's run fine on the same HW doesn't exclude it to be a
HW-centered problem.

I agree with the above, however since all these other OS's _do_ install and run
(and I really did try them) then it seems that the RH 8 installation process
stresses the hardware in some strange and unnecessary way.

A final note.  I have now been running RH 8 for about a week after doing my
upgrade from 7.3.  I am very happy with 8.0 except for the installation
problems.  I feel that RedHat support has closed this case without taking the
time to really read what has been said here.  I'm hope in time this problem will
be addressed, although RedHat chooses not to acknowledge it at the moment.  

Comment 30 deaston 2002-11-03 23:50:05 EST
Sorry it took so long to post this.  I've been tinkering...

Long story short is... SUCCESS!!!  I'm posting this from Mozilla on my now
functioning Redhat 8.0 install.  I wish I could tell you _EXACTLY_ what fixed
the problem, but unfortunately I gave up on the scientific method just starting
tinkering.  

What started me off on the right foot was based on some posts on usenet about
turning various options off during the install.  I went overboard and turned OFF
or disabled just about everything I could find (see "Appendix H" of the online
install guide for more info).

something like this (note:  I can't be sure if this is exactly what I used):

linux apm=off noapic noprobe nousb ide=nodma text

My installation succeeded for the first time.  There were a number of other
stubling blocks, like problems with USB not getting installed, keyboard problems
after starting X, video card issues, etc.  I've figured out how to get most of
this running from the command-line after I boot up, however I've yet to figure
out what files to edit so that it all gets enabled during the boot process. 
Specifically the USB thing.  I know I have to add some insmod commands, but I
don't know which file.

I'm sorry that I can't be more specific.  Best of luck to those having the same
problems.  I know how frustrating it is.  Also, thanks for the suggestions from
the other folks on this thread.  

Dan
Comment 31 deaston 2002-11-04 00:06:48 EST
I read through this thread a little more carefully and have a couple of things
to add:

1)  Yes, my install _was_ REALLY failing.  My point was just that it was
non-obvious because the last line implies that everything is rosy ("it is now
safe to reboot your system").  

2)  I saw the same behavior regardless of what packages I installed.  In fact, I
even went into the detailed package selection and deselected every package in
the list.  Still had the exact same failure.

The only final comment is that if I can provide anything else that might be
helpful (log files or such), let me know.  You may have to be VERY specific
though.  This is all still pretty foreign to me.

Comment 32 Gary Quiring 2003-03-14 20:08:40 EST
I recently changed hardware to a KT400 chipset board (Gigabyte GA-7VAX).  The 
already installed RH8 worked fine (20gig disk) with the new M/B.  I installed a 
WD120gig drive, attempted to install RH8 and get the exact same errors as noted.

Note You need to log in before you can comment on or make changes to this bug.