Bug 76048 - no mouse or keyboard in graphics mode
no mouse or keyboard in graphics mode
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bootp (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 00:37 EDT by Sabrina Chase
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 16:31:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sabrina Chase 2002-10-16 00:37:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3

Description of problem:
after logging in, running startx loads the desktop which displays properly, but
neither the mouse nor the keyboard can be used.  In text mode, if the mouse is
moved the keyboard locks up and the computer has to be completely restarted

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start computer.  Select Linux 7.3 from GRUB boot screen
2.login
3.type "startx" and hit return

	

Actual Results:  a hatched background with an x in the center appears, then the
Gnome desktop loads and displays.  The "Start Here" window is visible.  Any
attempt at input by mouse or computer has no effect.  Have to reboot computer to
do anything more.

Expected Results:  should be able to use keyboard shortcuts or mouse to interact
with desktop

Additional info:

Computer is a Dell Dimension 400Mhz PII.  Dual Boot with Windows 98. (no problem
with dual boot functionality).  Linux 7.3 is installed on a separate hard drive.
Mouse and keyboard are both PS/2.  IRQ settings show 01 for keyboard, 12 for
mouse.  Mouse is ordinary two-button generic mouse.  Note that the keyboard also
locks up if the mouse is moved in text mode.  I put in a service request
(#215153) and they have requested I file this bug.

Already attempted:
kbdconfig= no change
mouseconfig=no change
Xconfigurator= unable to create new config file.  When the test of Xwindows
comes up, the keyboard and mouse are locked and I am unable to confirm that I
can see the changed settings.
changing mouse and keyboard=no change

I am able to log in as root and as a system user and run commands just fine, so
Linux itself seems to be working normally.  It is only if the mouse is moved, or
if a graphical environment comes up that the keyboard and mouse lock.
Comment 1 Sabrina Chase 2002-11-12 11:31:31 EST
This issue has been resolved.  Investigation revealed the BIOS version was
Phoenix BIOS ver A07, and Dell had a version A08 available for download.  When
the new Bios version was installed, the mouse no longer conflicted the keyboard
and graphics mode was able to run correctly

Note You need to log in before you can comment on or make changes to this bug.