Bug 76075 - Can't shutdown an SMP kernel with power off.
Can't shutdown an SMP kernel with power off.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 12:13 EDT by Need Real Name
Modified: 2015-01-04 17:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 18:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-16 12:13:07 EDT
Description of Problem:
Can't shutdown the system with power down.
Using a SMP machine the power down step of the shutdown procedure
is not working. ( I have tried this to two different SMP machine, both
gave me the same results ). The system is closing all services, and 
printing on the screem the massage "Power Off", but doesn't do the 
power off. this problem cause our UPS to drain it's power till exhaust.
we tried this with the default kernel that comes with the distribution 
and also by compiling the kernel. ( on a SMP machine according to the kernel
documantation, the APM is disabled, if so, how one can powerdown the system ?)

Version-Release number of selected component (if applicable):
7.3

How Reproducible:
We use the following Hardware : Dell - PowerEdge 4400 ( Dual Xeon )
                                PC based of ASUS-CUV4X-DLS board ( Dual Pentium 
III ).
Use any SMP, type '>dmesg | grep APM', will show that the APM is disabled for 
SMP machine.
then, try to execute the command '>halt -p'.

Steps to Reproduce:
1. SMP machine, with an SMP kernel.
2. >halt -p
3. 

Actual Results:
Power stay on, and screen shows the message "Power Off".

Expected Results:
Killing the power of the machine. 
an attached UPS should read ~0% load.

Additional Information:
We installed Win2K with a multiprocessor support, and the Windows was
able to shutdown the system with the power completely down.
Comment 1 Aaron Schlaegel 2004-05-12 02:45:17 EDT
I have this same problem with a P4 using HT on FC1.

When I use smp kernels the system will not power off.

When I use non-smp kernels the system powers off as expected.
Comment 2 Aaron Schlaegel 2004-06-23 01:54:05 EDT
This bug is also in the current FC2.

It makes sense to assign this to fc2 since rh7.3 is not supported.
Comment 3 Chris 2004-08-12 10:52:03 EDT
This issue will only get more relevant as the popularity of
hyperthreading and dual-core CPUs increases at the consumer level, IMHO. 
Comment 4 David Masterson 2004-08-14 14:19:53 EDT
I have this problem too.  My system is an dual-cpu AMD MP 1800 machine
on a Tyan Tiger-MP motherboard.  The system seems to shutdown
properly, but does not powerdown at the end.  In FC2, it does seem to
"kick" something on my system, though, that stops the signal to the
monitor (the monitor reports no signal), but the system is still
powered on.  In FC1, the system would shutdown to the "Power Down"
message, but would not go any further.  RH8 also never powered down
this system.
Comment 5 Need Real Name 2004-10-29 15:24:01 EDT
ditto... same problem for me

fc1, dual athlon mp 1800 on tyan 2460 mb...
Comment 6 Aaron Schlaegel 2004-10-29 19:52:02 EDT
My issue has been fixed for some time with updated FC2 kernels.
Comment 7 David Masterson 2004-11-17 20:48:45 EST
My issue is now fixed with the update to the 2.6.9 FC2 kernel.
Comment 8 PPi 2004-12-17 16:09:29 EST
I actually have this problem with the SMP 2.6.9-1.6_FC2, and I did
*not* have it with the SMP 2.6.5-1.358.

MSI 865 PE NEO2 PFISR board. P4 3.0 GHz. 1x 100 GB WD, 1x250 GB
Hitachi (SATA).


Note You need to log in before you can comment on or make changes to this bug.