This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 760788 - Clone shortcut Alt+G collides with hotkey in browsers search functionality
Clone shortcut Alt+G collides with hotkey in browsers search functionality
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.4.1
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
https://translate.engineering.redhat....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-06 18:51 EST by Hedda Peters
Modified: 2013-03-03 21:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 00:21:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Search functionality at bottom of browser window (200.19 KB, image/png)
2011-12-06 18:56 EST, Hedda Peters
no flags Details

  None (edit)
Description Hedda Peters 2011-12-06 18:51:47 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.24) Gecko/20111108 Fedora/3.6.24-1.fc14 Firefox/3.6.24

When having the Browsers search functionality open (the little search bar that opens at the bottom of the window when pressing Ctrl+F), this search bar uses a number of hotkeys. These hotkeys are accessed by pressing Alt+letter. 

Pressing Alt+G in order to clone the msgid to msgstr does not work, because the browser instead uses this to activate the G-hotkey in the search bar (in this case toggling a certain check box)

This problem would be specific to the locale the browser is using - other languages might not use the hotkey Alt+G for anything.

Reproducible: Always

Steps to Reproduce:
1. browser locale needs to be German
2. open browser search bar with Ctrl+F
3. open editor for any string
4. hit Alt+G
Actual Results:  
Brower will toggle a checkbox in search bar. Msgid will not be cloned. Have to close the browsers search bar before being able to clone using Alt+G

Expected Results:  
Msgid should be cloned to msgstr.

No big deal I guess, if this is the whole scope of the problem. Something to keep an eye out for though, in case it affects other languages, other hotkeys, other functions.
Comment 1 Hedda Peters 2011-12-06 18:56:11 EST
Created attachment 541631 [details]
Search functionality at bottom of browser window
Comment 2 Hedda Peters 2012-02-01 22:52:53 EST
Seems to work fine now in Zanata version 1.4.5-alpha-1 (20120124-0107) with FF 9.
Alt+G triggers both, the cloning of the message as well as toggling the checkbox in the browser search bar.

However, now this new issue seems to be related: 
https://bugzilla.redhat.com/show_bug.cgi?id=786630

Note You need to log in before you can comment on or make changes to this bug.