Bug 7608 - rpms with kernel dependencies
rpms with kernel dependencies
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: knfsd (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-05 15:44 EST by Tim Pepper
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-22 11:12:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Pepper 1999-12-05 15:44:53 EST
I don't use the redhat kernel rpms and instead build my own kernels for
various reasons from the official source taballs.  This causes me to
continually have to force rpms to install because they've got dependencies
on the redhat kernel rpms, none of which are installed on my machines.  If
the rpms were built to check for the kernel version using 'uname' instead
of querying installed rpms, or at least had a fall back somehow to do this
if no kernel rpms were found, it seems like they would be more robust.  Is
there anyway you could do this in your rpms?

Perhaps this isn't so much a bug as a wish list item, and it certainly
isn't only knfsd that has this problem...still it seems buggy
that a rpm that requires functionality in a 2.2.x kernel would say it can't
install cause I don't have that kernel, when I in fact do.  In the meantime
I guess I can always force the installation, but I worry then if I'll miss
other real error messages.
Comment 1 Jeff Johnson 1999-12-22 11:12:59 EST
Try adding the missing dependencies to /etc/rpmrc, as in
	Provides: kernel

If you need to satisfy specific versions, you can also create a virtual
package that has, aside from the minimal name, vesrsion, ... required by
rpm, in a spec file
	Provides: kernel = x.y.z-abc	# substititue for x.y.z-abc

Build and install the virtual package to satisfy rpm dependencies w/o
actually installing Red Hat kernel rpm's.

Note You need to log in before you can comment on or make changes to this bug.