Bug 76087 - File permissions not preserved when importing file system
File permissions not preserved when importing file system
Status: CLOSED WORKSFORME
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Andrew Haley
eclipse-bugs
:
: 76725 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 14:25 EDT by Keith Seitz
Modified: 2006-09-27 14:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 14:04:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Seitz 2002-10-16 14:25:24 EDT
Description of Problem:
Eclipse doesn't preserve the file permissions on a checked out project; well, it
cannot do it, either, when just importing from an exiting file system!

Steps to Reproduce:
1. Create new C/C++ project (File->New->Project->C Project->blah blah blah)
2. File->import->file system
3. select some version of a sources.redhat.com project

Actual Results:
None of the configure scripts are executable

Expected Results:
File permissions should be preserved. I can't even imagine why they would
magically change when copying a file. Oh, wait, let me guess, don't trust the
OS! Write our own file system utilites.

Additional Information:
Comment 1 Need Real Name 2002-10-28 14:32:39 EST
*** Bug 76725 has been marked as a duplicate of this bug. ***
Comment 2 Tom Tromey 2002-12-04 17:24:37 EST
I've checked in the fix.
Comment 3 Jeremy Handcock 2003-08-20 11:22:58 EDT
Reopening: I'm not sure exactly when this reappeared, but I'm seeing this
behavior again in the beehive -15 RPM.

Related to: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100745
Comment 4 Andrew Haley 2003-08-22 09:40:31 EDT
I can confirm this problem still happens.

I'm looking at it.
Comment 5 Andrew Haley 2003-08-28 11:40:58 EDT
Fix checked in.
Comment 7 Tom Tromey 2006-09-27 14:04:41 EDT
This was fixed a long time ago.

Note You need to log in before you can comment on or make changes to this bug.