This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 761000 - Add support for the /usr move
Add support for the /usr move
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rpm (Show other bugs)
6.3
All Linux
urgent Severity medium
: rc
: 6.3
Assigned To: Panu Matilainen
Patrik Kis
:
Depends On: 760996
Blocks: 760997 760999
  Show dependency treegraph
 
Reported: 2011-12-07 09:49 EST by Harald Hoyer
Modified: 2012-06-20 10:23 EDT (History)
12 users (show)

See Also:
Fixed In Version: rpm-4.8.0-20.el6
Doc Type: Bug Fix
Doc Text:
Packages for Fedora >= 17 require a special rpmlib() dependency provided by rpm to track the /usr merge (http://fedoraproject.org/wiki/Features/UsrMove) being done in that version, otherwise it wont be possible to use eg. mock chroot to install and build packages for that distribution. This special tracking dependency has been added to rpm now to allow Red Hat Enterprise Linux 6 to be used as a host for building packages for these newer Fedora versions.
Story Points: ---
Clone Of: 760996
Environment:
Last Closed: 2012-06-20 10:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2011-12-07 09:49:36 EST
+++ This bug was initially created as a clone of Bug #760996 +++

Created attachment 541981 [details]
patch for rpm to provide checks for the usr move

To enable the /usr move
https://fedoraproject.org/wiki/Features/UsrMove
we need the attached patch in rpm.
This helps to guard against updating converted F17 packages on an unconverted system.
Comment 2 Panu Matilainen 2011-12-15 04:27:11 EST
CondNak on per-need basis - RHEL itself doesn't need this patch, this is only needed for the koji builders and there are three possibilities:

a) builders avoid the need for this by using a special version of filesystem package
a) builders use their own version of rpm with this patch applied (if a is not chosen this will be required temporarily anyway)
c) this patch gets applied to RHEL itself to eventually eliminate the need for a special version of rpm on the builders
Comment 3 Dennis Gilmore 2012-01-18 09:12:10 EST
From a fedora releng position I do not want to patch rpm on the builders at all. Please make it work without the need to. yes there has been cases in the past where we have done so. but it makes it really hard for people outside of Fedora to use rhel to build fedora rpms. which a lot of people do. its not a sustainable practice. especially since its a temporary measure its even better to avoid. since its likely to get forgotten in the future. patching rpm also makes life harder for secondary arches. and other consumers of rebuilding our sources.
Comment 4 Kay Sievers 2012-01-18 09:23:58 EST
(In reply to comment #3)
> From a fedora releng position I do not want to patch rpm on the builders at
> all. Please make it work without the need to.

Not sure, if that's really possible. Fedora 17 will not install any of the
converted packages on a system without the new RPM, or an unconverted
filessystem. That will obviously also applies to the builders.

Unless the builder always use --nodeps to install filesystem.rpm, or some other
trick, we need RPM in the builder provide the functionality needed by the
packages.

I don't have any idea for 'make it work without the need", and we need a
solution this week.

Any better idea?

Thanks!
Comment 5 Harald Hoyer 2012-01-20 11:17:16 EST
ok, so Dennis does not want a fork for the Fedora build system.

Panu, we need this in RHEL-6.3!
Comment 6 Panu Matilainen 2012-01-23 07:50:08 EST
While I'm not exactly eager to add Fedora-specific patches to RHEL (it wont be "temporary" at that point since we'll be forced to carry it for years to come) I guess I can live with that.

However adding it to RHEL-6.3 wont make it available on builders NOW.
Comment 17 Panu Matilainen 2012-05-24 09:41:57 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Packages for Fedora >= 17 require a special rpmlib() dependency provided by rpm to track the /usr merge (http://fedoraproject.org/wiki/Features/UsrMove) being done in that version, otherwise it wont be possible to use eg. mock chroot to install and build packages for that distribution. This special tracking dependency has been added to rpm now to allow Red Hat Enterprise Linux 6 to be used as a host for building packages for these newer Fedora versions.
Comment 18 errata-xmlrpc 2012-06-20 10:23:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0909.html

Note You need to log in before you can comment on or make changes to this bug.