Bug 761139 - new image xml validator should force rootpw element
new image xml validator should force rootpw element
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-07 13:45 EST by Dave Johnson
Modified: 2012-05-15 17:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 17:22:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2011-12-07 13:45:30 EST
Description of problem:
===================================
Testing the image validator, I noticed it does check for certain elements failing the xml with an appropriate error stating that the certain element is missing.  

However, it is not checking for the rootpw element which is required in oz templates which will not build without it.
Comment 1 wes hayutin 2011-12-07 14:29:58 EST
maybe just a warning.. ec2 certainly does not require a <passwd>
Comment 2 Dave Johnson 2011-12-07 16:01:22 EST
a related issue due to this issue...  bug 761200
Comment 3 Jan Provaznik 2011-12-12 10:37:46 EST
it turned out that rootpw is now reuired parameter in imagefactory for all targets, so I made this param required in relaxng schema -> now it's not possible to create template w/o roopw param.

commit ea32f345a3bfdee13d0f0aace0cec13f16ea093a
Comment 4 Shveta 2012-01-03 01:49:06 EST
Building image with a template without rootpw gives internal server error .
Not fixed. while building it from Ui gives error : "rootpw required"

[root@dell-pe1950-03 ~]# aeolus-image build --target ec2 --template fedora15.tpl 
ERROR:   => Failed.  Response code = 500.  Response message = Internal Server Error.
Comment 5 Jan Provaznik 2012-01-09 10:22:00 EST
patch for cli pushed in commit 0a37767d420060a3ef37e4ede2b760826416f3de
Comment 6 Steve Linabery 2012-01-10 13:05:19 EST
ea32f345a3bfdee13d0f0aace0cec13f16ea093a in aeolus-conductor-0.8.0-2.el6.src.rpm
Comment 7 Dave Johnson 2012-01-11 16:56:04 EST
good 2 go in aeolus-conductor-0.8.0-5.el6.noarch
Comment 8 wes hayutin 2012-01-12 11:18:00 EST
bugs in verified or on_qa moving off tracker
Comment 10 errata-xmlrpc 2012-05-15 17:22:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.