Bug 76115 - rhnreg_ks always gets Connection refused
rhnreg_ks always gets Connection refused
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-16 19:12 EDT by Ted Kaczmarek
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 20:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2002-10-16 19:12:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When trying to run rhnreg_ks it always fails with a connection refused.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run rhnreg_ks from terminal, with username, password and email options
2.fails every time with my Redhat 8.0 box
3.
	

Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/rhnreg_ks", line 294, in ?
    main()
  File "/usr/sbin/rhnreg_ks", line 248, in main
    ret = rhnreg.reserveUser(username, password)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 188, in reserveUser
    ret = rpcServer.doCall(s.registration.reserve_user, username, password)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 117, in doCall
    raise up2dateErrors.CommunicationError(e.args[1])
up2dateErrors.CommunicationError: Error communicating with server. The message was:
Connection refused


Expected Results:  Machine is registered.

Additional info:

This was a machine that was previosly registered with the same name, but the
profile has been deleted. I also tried with --force option gets the same error.
Latest attempt was 7:00pm est, but had same exact errors trying the last few days.
Comment 1 Mihai Ibanescu 2002-10-21 10:53:33 EDT
Can you please paste the output of:

grep -i serverURL /etc/sysconfig/rhn/rhn_register
grep -i serverURL /etc/sysconfig/rhn/up2date


Is your system behind a firewall? Would you have to use an HTTP proxy to browse
the web?

Also, what version of Red Hat Linux are you using?
rpm -q up2date
rpm -q rhn_register

would help as well.
Comment 2 Ted Kaczmarek 2002-10-22 08:03:14 EDT
Redhat 8.0. This box is the gateway, my other box behind this has no problems.
[tazman@nitremb22 tazman]$ su -l root
Password:
[root@nitremb22 root]# grep -i serverURL /etc/sysconfig/rhn/rhn_register
noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://www.rhns.redhat.com/XMLRPC
serverURL[comment]=Remote server URL
serverURL=https://www.rhns.redhat.com/XMLRPC
[root@nitremb22 root]# grep -i serverURL /etc/sysconfig/rhn/up2date
useNoSSLForPackages[comment]=Use the noSSLServerURL for package, package list, a
nd header fetching
noSSLServerURL[comment]=Remote server URL without SSL
noSSLServerURL=http://www.rhns.redhat.com/XMLRPC
serverURL[comment]=Remote server URL
serverURL=https://www.rhns.redhat.com/XMLRPC
[root@nitremb22 root]# rpm -q up2date
up2date-2.8.39-1.7.3
[root@nitremb22 root]# rpm -q up2date
up2date-2.8.39-1.7.3
[root@nitremb22 root]# rpm -q rhn_register
rhn_register-2.8.27-1.7.3
[root@nitremb22 root]#
Comment 3 Mihai Ibanescu 2002-10-22 12:26:40 EDT
Routing problem?

Try:

telnet www.rhns.redhat.com 443
telnet www.rhns.redhat.com 80

If the output is different than

Trying 66.187.232.100...
Connected to xmlrpc.rhn.redhat.com (66.187.232.100).
Escape character is '^]'.


then you have a routing/firewall problem on the gateway itself.
Comment 4 Ted Kaczmarek 2002-10-22 19:46:10 EDT
I get insulted about those types of question :-)[tazman@nitremb21 tazman]$
telnet www.rhns.redhat.com 443
Trying 66.187.232.100...
Connected to xmlrpc.rhn.redhat.com (66.187.232.100).
Escape character is '^]'.
^]^[Connection closed by foreign host.
[tazman@nitremb21 tazman]$ telnet www.rhns.redhat.com 80
Trying 66.187.232.100...
Connected to xmlrpc.rhn.redhat.com (66.187.232.100).
Escape character is '^]'.
^]
[root@nitremb21 root]# hping -S -p 80 www.redhat.com
HPING www.redhat.com (eth0 66.187.232.56): S set, 40 headers + 0 data bytes
len=46 ip=66.187.232.56 flags=SA DF seq=0 ttl=45 id=0 win=5840 rtt=27.6 ms
len=46 ip=66.187.232.56 flags=SA DF seq=1 ttl=45 id=0 win=5840 rtt=25.6 ms
len=46 ip=66.187.232.56 flags=SA DF seq=2 ttl=43 id=0 win=5840 rtt=33.3 ms
len=46 ip=66.187.232.56 flags=SA DF seq=3 ttl=45 id=0 win=5840 rtt=26.6 ms
len=46 ip=66.187.232.56 flags=SA DF seq=4 ttl=43 id=0 win=5840 rtt=35.1 ms
len=46 ip=66.187.232.56 flags=SA DF seq=5 ttl=45 id=0 win=5840 rtt=36.1 ms
len=46 ip=66.187.232.56 flags=SA DF seq=6 ttl=43 id=0 win=5840 rtt=36.1 ms
len=46 ip=66.187.232.56 flags=SA DF seq=7 ttl=45 id=0 win=5840 rtt=27.3 ms

--- www.redhat.com hping statistic ---
8 packets tramitted, 8 packets received, 0% packet loss
round-trip min/avg/max = 25.6/31.0/36.1 ms
[root@nitremb21 root]# hping -S -p 443 www.redhat.com
HPING www.redhat.com (eth0 66.187.232.56): S set, 40 headers + 0 data bytes
len=46 ip=66.187.232.56 flags=SA DF seq=0 ttl=45 id=0 win=5840 rtt=26.7 ms
len=46 ip=66.187.232.56 flags=SA DF seq=1 ttl=45 id=0 win=5840 rtt=25.6 ms
len=46 ip=66.187.232.56 flags=SA DF seq=2 ttl=43 id=0 win=5840 rtt=34.4 ms
len=46 ip=66.187.232.56 flags=SA DF seq=3 ttl=43 id=0 win=5840 rtt=253.1 ms
len=46 ip=66.187.232.56 flags=SA DF seq=4 ttl=43 id=0 win=5840 rtt=37.4 ms
len=46 ip=66.187.232.56 flags=SA DF seq=5 ttl=45 id=0 win=5840 rtt=27.1 ms
len=46 ip=66.187.232.56 flags=SA DF seq=6 ttl=43 id=0 win=5840 rtt=34.0 ms
len=46 ip=66.187.232.56 flags=SA DF seq=7 ttl=43 id=0 win=5840 rtt=34.0 ms
len=46 ip=66.187.232.56 flags=SA DF seq=8 ttl=45 id=0 win=5840 rtt=25.3 ms

--- www.redhat.com hping statistic ---
9 packets tramitted, 9 packets received, 0% packet loss
round-trip min/avg/max = 25.3/55.3/253.1 ms
[root@nitremb21 root]#

If you want access to the box for testing I would be more than happy to accomodate.

This same install also has an issue with neat, the bug was assigned to ipcalc,
maybe something their? I have seen and done other installs, this one in
particular seems to be funky. Weird part is I made the first CD's and everyone
else got copies of them, so I ruled anything wacky like that out.
Comment 5 Mihai Ibanescu 2002-10-22 19:58:32 EDT
Don't feel insulted, I'm just trying to pinpoint the problem :-)
Clearly there is a connectivity problem. Please paste:

grep -i proxy /etc/sysconfig/rhn/up2date
grep -i proxy /etc/sysconfig/rhn/rhn_register

Comment 6 Ted Kaczmarek 2002-10-22 20:06:06 EDT
[root@nitremb21 root]# grep -i proxy /etc/sysconfig/rhn/up2date
enableProxyAuth[comment]=To use an authenticated proxy or not
enableProxyAuth=0
enableProxy[comment]=Use a HTTP Proxy
enableProxy=1
proxyPassword[comment]=The password to use for an authenticated proxy
proxyPassword=
proxyUser[comment]=The username for an authenticated proxy
proxyUser=
httpProxy[comment]=HTTP proxy in host:port format, e.g. squid.redhat.com:3128
httpProxy=172.16.201.22:3180

[root@nitremb21 root]# grep -i proxy /etc/sysconfig/rhn/rhn_register
grep: /etc/sysconfig/rhn/rhn_register: No such file or directory
[root@nitremb21 root]#


Comment 7 Mihai Ibanescu 2002-10-22 20:12:21 EDT
Okay, you have enabled a proxy (as shown by the line enableProxy=1)
httpProxy=172.16.201.22:3180 shows the proxy's address.

You can either:
- set enableProxy=0
- check to see if the proxy exists and make sure its ACLs allow you to connect
from this box.

To prove the problem:

telnet 172.16.201.22 3180
Comment 8 Ted Kaczmarek 2002-10-22 20:25:55 EDT
Thank you so very much, I was running squid for my wife till I got the firewall
rules setup right. If your ever in NYC area, I owe you some drinks :-). Email me,
no joking.
If your mistakes don't cost you anything you don't learn as much from them.
Comment 9 Mihai Ibanescu 2002-10-23 10:07:53 EDT
I wish there was a method one could ftp or scp a beer. :-)
Closing this one.

Note You need to log in before you can comment on or make changes to this bug.