Bug 76130 - 'ImportError: cannot import name up2dateLog' when running up2date for second time
'ImportError: cannot import name up2dateLog' when running up2date for second ...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 05:39 EDT by Daniel
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 17:06:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel 2002-10-17 05:39:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
The error message 'ImportError: cannot import name up2dateLog' when running 
up2date a second time and all subsequent times.

[root@zebedee root]# up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 14, in ?
    from up2date_client import up2dateLog
ImportError: cannot import name up2dateLog

up2date will not progress any further than this point.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make key, run up2date turning keychecking off.
2. Run up2date, allow it to complete normally.
3. Run up2date *again*.
	

Actual Results:  I cannot reproduce the whole sequence of events because of the 
nature of the program.

Additional info:
Comment 1 Adrian Likins 2002-10-18 17:07:13 EDT
whats the output of:
    rpm -V up2date

looks like some files didnt get installed properly...
Comment 2 Daniel 2002-10-22 03:28:16 EDT
[root@zebedee root]# rpm -V up2date
.......T c /etc/logrotate.d/up2date
S.5....T   /etc/rc.d/init.d/rhnsd
..5....T c /etc/sysconfig/rhn/rhnsd
SM5....T c /etc/sysconfig/rhn/up2date
S.5....T   /usr/sbin/rhn_check
S.5....T   /usr/sbin/rhnsd
S.5....T   /usr/sbin/up2date
S.5....T   /usr/share/rhn/up2date_client/bootloadercfg.pyc
S.5....T   /usr/share/rhn/up2date_client/checkbootloader.pyc
S.5....T   /usr/share/rhn/up2date_client/clap.pyc
S.5....T   /usr/share/rhn/up2date_client/config.pyc
S.5....T   /usr/share/rhn/up2date_client/getMethod.pyc
S.5....T   /usr/share/rhn/up2date_client/iutil.pyc
S.5....T   /usr/share/rhn/up2date_client/lilo.pyc
S.5....T   /usr/share/rhn/up2date_client/lilocfg.pyc
S.5....T   /usr/share/rhn/up2date_client/rhnDefines.pyc
S.5....T   /usr/share/rhn/up2date_client/rhnHTTPlib.pyc
S.5....T   /usr/share/rhn/up2date_client/rpmSource.pyc
S.5....T   /usr/share/rhn/up2date_client/text_config.pyc
S.5....T   /usr/share/rhn/up2date_client/translate.pyc
S.5....T   /usr/share/rhn/up2date_client/up2date.pyc
S.5....T   /usr/share/rhn/up2date_client/up2dateUtils.pyc
S.5....T   /usr/share/rhn/up2date_client/wrapper.pyc
[root@zebedee root]#
Comment 3 Adrian Likins 2003-01-21 00:26:58 EST
Can you try:

% cd /usr/share/rhn/up2date_client
% python
>>> import up2dateLog

Also, whats:

      ls -la /usr/share/rhn/up2date_client/up2dateLog.py

the `rpm -V` output seems to indicate the file is there and
isn't corrupt, so offhand, I'm not sure what would cause it
to not import correctly.

Comment 4 Daniel 2003-01-21 06:21:26 EST
That filename you gave me doesn't exist. Here's the output you needed.

[root@zebedee root]# cd /usr/share/rhn/up2date_client
[root@zebedee up2date_client]# python
Python 1.5.2 (#1, Jul  5 2001, 03:02:19)  [GCC 2.96 20000731 (Red Hat Linux 7.1 
2 on linux-i386
Copyright 1991-1995 Stichting Mathematisch Centrum, Amsterdam
>>> import up2dateLog
Traceback (innermost last):
  File "<stdin>", line 1, in ?
ImportError: No module named up2dateLog
>>>
[root@zebedee up2date_client]# ls -la up*.py
-rwxr-xr-x    1 root     root        69754 Sep  7  2001 up2date.py
-rwxr-xr-x    1 root     root         7629 Sep  7  2001 up2dateUtils.py
[root@zebedee up2date_client]#
Comment 5 Adrian Likins 2004-04-05 17:06:20 EDT
That package definately didnt get installed correctly
(or disturbed somehow post installation)
Why that is, I dont know, but thats the cause
of the up2date bug reported here.  

Note You need to log in before you can comment on or make changes to this bug.