Bug 76148 - Kernel update 2.4.18-17.8.0 causes esd to hang on Dell Latitude C800
Kernel update 2.4.18-17.8.0 causes esd to hang on Dell Latitude C800
Status: CLOSED DUPLICATE of bug 76171
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-17 12:04 EDT by Mick Smothers
Modified: 2007-04-18 12:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-23 11:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mick Smothers 2002-10-17 12:04:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009

Description of problem:
After updating the 8.0 kernel via RHN, the gnome desktop (specifically Nautilus
and panels) hangs after starting apps from the panel. Also no sound is produced.
After jumping to a shell and killing the esd process, the gnome session comes
back to life, but of course no sound.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RH Linux 8.0 on a Dell Latitude C800 laptop (has a P3 1GHz and 512MB
RAM if that matters, and has an ES1983S Maestro 3i PCI integrated sound card,
that probably does matter)
2. Apply all updates available via up2date from RHN
3. reboot and then log in to the gnome session with a user login (didn't try it
with root) and start a few apps. Starting evolution and/or rt click on the
Volume Control panel applet and starting the Volume Control app seems to do the

Actual Results:  The panel stops repainting and no other apps can be started
from Gnome it seems until the esd process is killed.

Expected Results:  everything should work like it does on the original kernel

Additional info:

Booting the original kernel, everything works fine.
Comment 1 adam.huffman 2002-10-18 12:28:18 EDT
I'm seeing this too on the same model.  If I boot from the -14 kernel sound works  
Comment 2 Don Hardaway 2002-10-18 15:18:26 EDT
My C800 has the same problem also!!
Comment 3 Pierre F. Maldague 2002-10-19 00:40:16 EDT
I have a Dell Inspiron 4000 (P III 600 MHz, ESS Maestro3(i) sound device) and
the symptoms are somewhat different but I think could be related. I observed the
following after updating to the new kernel (2.4.18-17.8.0) via up2date.

- apps inside nautilus don't freeze, they just crash often (not always), e. g.
the first time I select "system settings" as root. I don't think I saw this
behavior with the original kernel (2.4.18-14).

- CDs can play (at fairly low volume) but the sound control panel has no effect
and I can't play sounds for events.

I reverted to the original kernel and the problems disappeared.
Comment 4 Need Real Name 2002-10-19 13:46:27 EDT
Same problem with Dell Latitude C600. Reverting fixes.
Comment 5 James Segarra 2002-10-20 11:33:48 EDT
I have a Dell Inspiron 8100 and the same problem. No more sound after the kernel
Comment 6 Elliot Peele 2002-10-21 14:05:54 EDT
I'm seeing the a similar problem on a Dell Latitude C810 with the ESS Maestro3
card after the kernel upgrade of just not having any sound at all. When trying
to play sound there are problems loading the sound-slot-1 and sound-service-1-0

Oct 21 13:22:01 nebuchadnezzar modprobe: modprobe: Can't locate module sound-slot-1
Oct 21 13:22:01 nebuchadnezzar modprobe: modprobe: Can't locate module

Comment 7 Eli Barzilay 2002-10-23 03:10:40 EDT
Add another C600 to the list...
Even worse for me since using the old kernel didn't fix it -- even uninstalling
the newer one didn't help -- I'm running with 2.4.18-14 and esd is very dead.
(If anyone who gets this knows what to do to revive it with the old kernel I
will be happy for a hint...)
Comment 8 Eli Barzilay 2002-10-23 11:43:15 EDT
For the record, in case someone else panics when booting the old kernel doesn't
work -- I could get it to work after powering the machine down.
Comment 9 Bill Nottingham 2002-10-26 00:46:44 EDT

*** This bug has been marked as a duplicate of 76171 ***

Note You need to log in before you can comment on or make changes to this bug.