This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76167 - strace fixes needed for ppc
strace fixes needed for ppc
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: strace (Show other bugs)
1.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 15:18 EDT by Guy Streeter
Modified: 2016-02-09 20:32 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 18:01:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ppc fixes (671 bytes, patch)
2002-10-17 15:19 EDT, Guy Streeter
no flags Details | Diff
ppc fixes (936 bytes, patch)
2002-10-17 15:20 EDT, Guy Streeter
no flags Details | Diff

  None (edit)
Description Guy Streeter 2002-10-17 15:18:41 EDT
I will attach source and specfile diffs needed for ppc.
Comment 1 Guy Streeter 2002-10-17 15:19:26 EDT
Created attachment 80825 [details]
ppc fixes
Comment 2 Guy Streeter 2002-10-17 15:20:08 EDT
Created attachment 80826 [details]
ppc fixes
Comment 3 Roland McGrath 2002-12-15 18:13:38 EST
Your diff fixes the insn used for LOOP, and adds a cast.
I'll push the insn fix upstream.  The cast I do not see a need for.
Comment 4 Guy Streeter 2002-12-16 10:37:39 EST
The cast is necessary because st_size is a long and the printf format is a long
long. Uncast, this will print garbage.
Comment 5 Roland McGrath 2002-12-16 15:19:58 EST
There is a problem with the compilation environment if the st_size member
of struct stat64 does not have type long long.  On my ppc machine, it does.

Comment 6 Roland McGrath 2003-01-10 18:01:33 EST
Version 4.4.91-1 should work fine.

Note You need to log in before you can comment on or make changes to this bug.