Bug 76175 - Instructions on how to exit a terminal window are invalid
Instructions on how to exit a terminal window are invalid
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rhl-gsg (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Ha
John Ha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 16:21 EDT by Mark Harig
Modified: 2014-08-04 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 10:51:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Harig 2002-10-17 16:21:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
On page 18, Chapter 1 "Getting Started", the fourth paragraph says that the user
can exit a terminal window if they "...type exit at the prompt, or press
[Ctrl]-[D] at the prompt."  This does not work in the default terminal window
for GNOME, gnome-terminal 2.0.1.  Instead the user can either select 'Close
Window' from the 'File' menu or type [Ctrl]-[Shift]-[Q], in addition to clicking
on the 'X' button.


Version-Release number of selected component (if applicable):

rhl-gsg(EN)-8.0-Print-RHI (2002-08-20T12:16-0400)

How reproducible:
Always

Steps to Reproduce:
1. Read page 18 of the Getting Started manual.
2.
3.
	

Additional info:
Comment 1 Douglas Furlong 2002-10-17 21:07:43 EDT
I have just quickly checked the instructions available on the Getting started guide.

I am running the standard install with the GNOME desktop. As far as I am aware I
have performed no alterations to my set-up as far as the terminal window is
concerned (Accessed By RedHat -> System Tools -> Terminal).

From what I can see the instructions included work fine, CTRL + D and exit both
work with out a hitch.

CTRL + SHIFT + Q also work as does clicking the X button and of course selecting
Close Window from the File menu.

Hope this is of use.

Doug
Comment 2 Mark Harig 2002-10-18 10:50:56 EDT
Please provide more specifics.

What version of gnome terminal?  What version of Red Hat Linux?

Which "standard" installation did you choose?  There is no single standard 
installation.  There are several standard installations.  I chose 
the 'Workstation' standard installation.

I have never used gnome terminal before RH 8.0, so I did not have any settings 
other than the ones Red Hat provides.

Comment 3 John Ha 2002-10-18 14:28:14 EDT
I have tested the graphical (GNOME) terminal (Main Menu => System Tools =>
Terminal) behavior using a "Workstation" installation of Red Hat Linux 8.0 and
it is dismissed with both the 'exit' command and [ctrl]-[d] shortcut. The
documentation is correct using a Workstation installation of Red Hat Linux 8.0.

Some suggestions:

Note any errors you receive when you type 'exit' (or press [ctrl]-[d]) at the
GNOME terminal. 

Make sure you have not assigned another system behavior to [ctrl]-[d] in Main
Menu => Preferences => Keyboard Shortcuts that may affect the terminal exit
shortcut.

In some instances (but not often), a custom keyboard layout (for example, to map
a nationalized keyboard) can cause alternate behaviors from the default English
keyboard layout.

Please feel free to add to this bug report if you find a resolution; however I
am closing it because the instructions documented are correct. Thanks to all for
your input.
Comment 4 Mark Harig 2002-10-18 14:50:59 EDT
I tried using 'exit' early on (that has been my traditional way for dismissing 
a terminal window).  When it did not work, I tried Ctrl-D.  Both cause the 
window to "flash" (as though it is shutting down and restarting).  I thought it 
might be a new feature in gnome-terminal, as opposed to the traditional xterm, 
that had been added to prevent users from accidentally dismissing their windows.
Because you say that this is not the expected behavior, I agree that this bug 
report should be closed.  I will return to this bug report if I discover what 
is causing the behavior of gnome-terminal that I am seeing.

Note You need to log in before you can comment on or make changes to this bug.