Bug 76187 - traceback: AttributeError: initUp2dateConfig
traceback: AttributeError: initUp2dateConfig
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-17 18:52 EDT by Mike McLean
Modified: 2015-01-07 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 17:08:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
up2date log (4.82 KB, text/plain)
2002-10-17 19:00 EDT, Mike McLean
no flags Details
kickstart file (1.08 KB, text/plain)
2002-10-17 19:01 EDT, Mike McLean
no flags Details
up2date log from adolphus 19apr2k3 (6.78 KB, text/plain)
2003-04-19 17:26 EDT, Need Real Name
no flags Details

  None (edit)
Description Mike McLean 2002-10-17 18:52:21 EDT
On a fresh 2.1AS install, I'm getting a traceback in up2date while installing
up2date. Will attach.

The 2.1AS install was automated, will attach kickstart file.

This is also happening with RH7.2
Comment 1 Mike McLean 2002-10-17 18:53:35 EDT
Gaa. nevermind, *not* 2.1AS, 7.2 only so far....
Comment 2 Mike McLean 2002-10-17 18:59:46 EDT
In a nutshell, I installed 7.2 with the following %packages:
@ Base
gmp
python
rpm-python
python-xmlrpc
gnupg
rhn_register
up2date

Then I upgraded the following errata packages from the ftp updates dir
(I'm not sure why, but there are two versions of up2date/rhn_register available
there).
rhn_register-2.7.9-7.x.2
up2date-2.7.61-7.x.2

Then I ran up2date.
Comment 3 Mike McLean 2002-10-17 19:00:33 EDT
Created attachment 80885 [details]
up2date log
Comment 4 Mike McLean 2002-10-17 19:01:27 EDT
Created attachment 80886 [details]
kickstart file
Comment 5 Adrian Likins 2002-10-18 17:33:33 EDT
currently not able to reproduce this, but am trying...

Comment 6 Bill McCarty 2002-11-01 22:45:57 EST
I've just seen what seems to be this same problem with two RHL 7.2 systems:

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1137, in ?
  File "/usr/sbin/up2date", line 388, in main
    rpm.setVerbosity(rpm.RPMLOG_DEBUG)
  File "/usr/sbin/up2date", line 1116, in batchRun
  File "/usr/share/rhn/up2date_client/up2date.py", line 2361, in 
installBootLoader
  File "/usr/share/rhn/up2date_client/up2date.py", line 2380, in __install_grub
  File "/usr/share/rhn/up2date_client/grubcfg.py", line 16, in ?
    import rpmUtils
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 22, in ?
    import up2dateErrors
  File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 11, in ?
    import up2dateLog
  File "/usr/share/rhn/up2date_client/up2dateLog.py", line 8, in ?
    cfg = config.initUp2dateConfig()
AttributeError: initUp2dateConfig

The up2date log shows:
[Sat Nov  2 03:40:54 2002] up2date new up2date run started
[Sat Nov  2 03:40:54 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Nov  2 03:40:55 2002] up2date updating login info
[Sat Nov  2 03:40:55 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Sat Nov  2 03:40:55 2002] up2date logging into up2date server
[Sat Nov  2 03:40:55 2002] up2date successfully retrieved authentication token 
from up2date server
[Sat Nov  2 03:40:55 2002] up2date Updating package profile
[Sat Nov  2 03:40:55 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
Comment 7 Need Real Name 2003-04-19 17:26:59 EDT
Created attachment 91195 [details]
up2date log from adolphus 19apr2k3

this just occurred on rh7.3:

[root@adolphus /]# up2date
warning: /etc/sysconfig/rhn/rhn_register created as
/etc/sysconfig/rhn/rhn_register.rpmnew
warning: /etc/sysconfig/rhn/up2date created as
/etc/sysconfig/rhn/up2date.rpmnewTraceback (innermost last):
  File "/usr/share/rhn/up2date_client/gui.py", line 872, in doInstallation
    hdr[rpm.RPMTAG_RELEASE])
  File "/usr/share/rhn/up2date_client/up2date.py", line 2400, in
installBootLoader
  File "/usr/share/rhn/up2date_client/up2date.py", line 2419, in __install_grub

  File "/usr/share/rhn/up2date_client/grubcfg.py", line 16, in ?
    import rpmUtils 
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 22, in ?
    import up2dateErrors
  File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 11, in ?
    import up2dateLog
  File "/usr/share/rhn/up2date_client/up2dateLog.py", line 8, in ?
    cfg = config.initUp2dateConfig()
AttributeError: initUp2dateConfig
Comment 8 Adrian Likins 2004-04-05 17:08:53 EDT
Shouldnt be an issue with current releases (no late imports
of modules)

Note You need to log in before you can comment on or make changes to this bug.