Bug 76195 - 2.2.22 pcmcia_core.o unresolved symbols
Summary: 2.2.22 pcmcia_core.o unresolved symbols
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-18 01:06 UTC by Need Real Name
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 04:37:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-18 01:06:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
ran up2date.  got 2.2.22 kernel + pcmcia.  rebooted.  no pcmcia.
turns out the 2.2.22-7.0.2 pcmcia package contains a pcmcia_core.o
which won't modload (insmod) due to "request_mem_region" unresolved.
(note this worked fine with previous 2.2.19 kernel)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. upgrade from 2.2.19 to 2.2.22 kernel on RH 7.0 system
2. note that pcmcia fails to load
3. regress to 2.2.19 kernel :-)
	

Additional info:

All I did was run up2date.  My previous 2.2.19 kernel worked like
a champ - pcmcia worked fine.  After upgrading to 2.2.22 kernel I had
no pcmcia.  I did "lsmod" and noticed no pcmcia_core.o or i82365.o
was loaded.  humm, I thought.  so I "modprobe pcmcia_core" and see
unresolved symbols.  bummer.

If I did something wrong, please send a clue...

Comment 1 David Lowe 2002-11-02 19:09:33 UTC
I had the same problem. Tried recompiling pcmcia-cs using the 2.2.22 RH7.0
source tree, but that gave the same unresolved symbols. Downloading the latest
pcmcia-cs source from sourceforge.net and compiling finally got things working.

Comment 2 John Gotts 2002-11-08 03:00:52 UTC
This was a nasty bug for me because I installed the updates on a machine without
a CD-ROM.  A PCMCIA CD-ROM would of course have not worked.  I had to copy a
functional kernel with modules by floppy because without PCMCIA the machine was
otherwise inaccessible from the outside world.


Note You need to log in before you can comment on or make changes to this bug.