Bug 76231 - loadkeys gives error on dead key codes
loadkeys gives error on dead key codes
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-18 10:56 EDT by Stian Sletner
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-14 12:33:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Norwegian console keymap (1.98 KB, application/octet-stream)
2003-03-29 11:43 EST, Stian Sletner
no flags Details

  None (edit)
Description Stian Sletner 2002-10-18 10:56:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I have a custom keymap for Norwegian (that I hope to submit to be the default
eventually, as it matches the keyboard better than the old, crufty `no' and
`no-latin1' maps that are bundled).  It uses the feature of making dead keys
using 0x0dxx codes in the keymaps.  Lines like these:

    keycode  27 = 0x0da8    dead_circumflex dead_tilde
    keycode  13 = backslash dead_grave      0x0db4          notsign
    keycode  51 = comma     semicolon       0x0db8       guillemotleft

I've used this successfully for several versions (at least all of 7.x), but in
8.0 it craps:

    KDSKBENT: Invalid argument
    failed to bind key 27 to value 3496
    KDSKBENT: Invalid argument
    failed to bind key 13 to value 3508
    KDSKBENT: Invalid argument
    failed to bind key 51 to value 3512

I talked to Brouwer, the kbd guy, and he said it worked for him (and did not
mention having done any changes that would make it not work), so I assume this
is something inflicted by RH.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try the keymap lines in the Description, or download and loadkeys
http://home.powertech.no/sletner/no-standard.kmap.gz
2. Watch.
3. Weep.
	

Actual Results:  
    KDSKBENT: Invalid argument
    failed to bind key 27 to value 3496
    KDSKBENT: Invalid argument
    failed to bind key 13 to value 3508
    KDSKBENT: Invalid argument
    failed to bind key 51 to value 3512


Additional info:
Comment 1 Stian Sletner 2003-02-12 16:16:43 EST
This went away when compiling a custom kernel.  Can RH kernel patches have
broken something?  Anyway, bump.  I see there's a new component owner.  Maybe
this one actually reads bugzilla. :-)
Comment 2 Eido Inoue 2003-02-12 17:29:52 EST
Question about your custom config: are you running in Unicode mode? (Unicode no
locale, kbd_mode -u and using unicode_start?)

If not, can you try with your kernel and tell me the results?
Comment 3 Stian Sletner 2003-02-13 02:32:19 EST
No, I'm not using Unicode mode.  I'm not exactly sure what you're asking now,
Unicode mode on the console in RH8 is pretty broken with or without my custom
map (which is clearly an ISO 8859-1 map).  I do not use a "no" locale at all,
btw, and I remove the utf8 part in /etc/sysconfig/i18n to get out of Unicode
mode.  I did do a little test now though, and Unicode mode does indeed seem to
break all the dead keys (and not only the ones I've added, either).  By the way,
how would I go about submitting my map to be included in RH?  Ideally, it would
replace the map called "no", which is useless.
Comment 4 Eido Inoue 2003-02-13 15:43:20 EST
Please submit it (preferrably gzipped) as a patch to this bug report. It
probably won't make it into the next release, but will be sent via RHN as an
errata and the next release.

Please make sure it's right-- I don't have a no keyboard (have to rely on scan
codes) and nobody speaks no either (we used to have a dev, but not anymore. :( )

RH8 and beyond has standardized on Unicode for all single-byte locales... CJK
are on the roadmap. While we will be looking at backwards compatiblity, 8+ will
ship with Unicode enabled on the console by default.
Comment 5 Stian Sletner 2003-03-29 11:43:12 EST
Created attachment 90787 [details]
Norwegian console keymap

Hello again (I've been away for a while).  Attachment created.	You should
verify that this loads without error on whatever kernel version it will be
bundled with, because as mentioned the stock 8.0 kernel chokes on it for some
reason.  About it being bugfree and perfect, well, all I can say is that I've
been using this myself for a couple of years and have ironed out anything I've
found.	It should be fine.
Comment 6 Stian Sletner 2003-03-29 12:10:07 EST
So, on closer thought it seems the kmap description language is far from
perfect, as it makes me hardcode ISO 8859-1 things at certain spots.  I guess I
could whip up an UTF version of the same map.  Would that be desired?
Comment 7 Eido Inoue 2003-07-14 12:33:18 EDT
non-ASCII input into the console won't be supported on UTF-8 based systems (RHL
8+) until the kernel supports it. See the release notes in the next beta for
more info. Of course, input through X will always be supported.

Note You need to log in before you can comment on or make changes to this bug.